Cannot remove email channel

Infos:

  • Used Zammad version: 6.2.0-1702975436.87754a02.focal
  • Used Zammad installation type: package
  • Operating system: Ubuntu 22.04.3 LTS
  • Browser + version: Edge v120

Expected behavior:

Actual behavior:

Steps to reproduce the behavior:

  • Not sure how to reproduce this, we have switched from Email channel to Microsoft 365 channel and did Delete the email channel, but the Email channel still shows an Outbound account.

We had left it as it is because everything else works fine with Microsoft 365, and we have no usability issues. But from October 2023, with Microsoft disabling basic auth for SMTP, we are seeing this "Can’t use Channel::Driver::Smtp: #<Net::SMTPAuthenticationError:Net::SMTPAuthenticationError>

I’m sure Zammad is not using this channel at all because all communications are going through the Microsoft 365 channel successfully, and we see no errors in the M365 account configuration.

Same problem here… also the monitoring page shows an error beause of this issue. Switched from local mail server to m365 anf cannot delete normal e-mail account.

You’re mixing up “Email accounts” with the notification account.
The notification channel is technically mandatory and a requirement of Zammad for e.g. agent notifications.

You can configure it to use either SMTP or sendmail.
There’s no possibility to remove it.

Thank you so much for your reply. Could you kindly help for the resolution for the Net::SMTPAuthenticationError (which as I explained started from October 2023, ever since Microsoft permanently switched off basic SMTP auth). As ISFM-IT mentioned, sometimes we see errors in “Monitoring” view due to this.

Some times I’m also getting unprocessable mails error, which I resolve by running sudo zammad run rails r ‘Channel::EmailParser.process_unprocessable_mails’ command. Is the SMTP error somehow causing these unprocessable mails?

You’re indirectly answering your question yourself:

The notification channel, as I mentioned, supports SMTP and sendmail.
It however does not support XOAUTH for Google or Microsoft 365.

The documentation also states this.
So a send connector just for your Zammad instance that doesn’t require authentication (make sure to only allow it for your Zammad host…) could be the solution.

Other solutions might be feasable as well, but depend on your environment and what you can technically do. Most people decide for providers like Microsoft or Google for reasons, be it functionality or “it just working” (most of the times).

Sorry but I don’t think I have answered myself. The question here is to how to prevent the error in the channel (which also creates error in Monitoring). So, your suggestion is to configure a dummy send connector? I feel this is a bug, shall I file a bug report so that Zammad stops trying to authenticate using plain SMTP when server is smtp.office365.com?

It is not.

Configure a different MTA apart of Microsoft tat supports basic authentication for SMTP.

If you believe this is a missing functionality (as in Zammad should have a Microsoft 365 notification channel), look through the existing feature requests and if you don’t find one, create one here:

Back in the days I did answer that question.

So: Install sendmail with it’s dependencies or use a SMTP server. Otherwise there’s no option.