Tags are not saved

Infos:

  • Used Zammad version: 3.5
  • Used Zammad installation source: (source, package, …)
  • Operating system: Ubuntu 18.04
  • Browser + version: all

Since the update to version 3.5 we have noticed 2 problems.

  • Tags can be selected and confirmed. However, the selection of the tags is lost when the ticket is saved.
    image
    image
    image

  • Merging two tickets no longer works. Error API - seams to be the same like here Merging Tickets fails in 3.5

Same Problem here. I installed Zammad 3.5 yesterday over 3.4 via
deb https://dl.packager.io/srv/deb/zammad/zammad/stable/ubuntu 18.04 main
Tags are not saved. Please help.

Das findet sich in den Logs:
I, [2020-10-14T10:32:15.876240 #52604-47164867198200] INFO – : Started GET “/api/v1/tag_search?term=” for 80.151.xx.xx at 2020-10-14 10:32:15 +0200
I, [2020-10-14T10:32:19.817239 #52604-47164867197080] INFO – : Started GET “/api/v1/tags/add?object=Ticket&o_id=151906&item=3D+Glasfoto&=1602664331627" for 80.151.xx.xx at 2020-10-14 10:32:19 +0200
I, [2020-10-14T10:32:19.830207 #52604-47164867197080] INFO – : Parameters: {“object”=>“Ticket”, “o_id”=>“151906”, “item”=>“3D Glasfoto”, "
”=>“1602664331627”, “a”=>“api/v1/tags/add”}
E, [2020-10-14T10:32:19.838322 #52604-47164867197080] ERROR – : No route matches [GET] /api/v1/tags/add (ActionController::RoutingError)

For completness here again as well:

  • ensure that your browser doesn’t use cached versions of Zammad (aka clear your browser cache)
  • ensure that you’re on latest Zammad 3.5

Your issues should vanish then.

Does not work. I removed cookies, removed cache. Tried browser i never used for zammad (edge) but i cannot set tags. Version shows "Dies ist die Zammad Version 3.5.x "

Found my problem: I had to remove an old symlink within /opt/zammad/public/assets (quickfix for zammad 3.2 upgrade), see my old post:


Now everything works. Thank you!

That does’nt fix the Problem.
In Firefox, it looks like the tag is being saved. If you close the ticket and open it again, the Tag is gone.
In Chrome(ium) the page is reloaded when saving and the tag is gone.

If we would merge two Tickets, we get this message
image

zammad run rake assets:precompile and a reboot of the VM fixed the Tag- and the merge-problem.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.