"Skip trigger (#{trigger.name}/#{trigger.id}) because sender do not want to get auto responder for object (Ticket/#{ticket.id}/Article/#{article.id})"


  • Used Zammad version: 2.6.0
  • Used Zammad installation source: Docker zammad/zammad
  • Operating system: Mac OSX 10.12.6
  • Browser + version: Safari 11.1.1

Expected behavior:

  • default filter “auto reply (on new tickets)” to send auto reply email

Actual behavior:

  • no email is sent
  • production.log contains the following entry:
    Skip trigger (auto reply (on new tickets)/1) because sender do not want to get auto responder for object

Steps to reproduce the behavior:

  • Email channel and customer use the same domain i.e. @domain.com
  • If I send an email (as a customer), I receive auto reply email and everything works as expected

Edit: My question is - why do I get this message and how I avoid it?

Could you please provide the headers of the E-Mail where this happens?

Delivered-To: alex.kucheryuk@eltoma-offshore.com
Return-Path: <olga@eltoma-dev.com>
Delivered-To: alex.kucheryuk@eltoma-offshore.com
Received: from director10.mail.iad3b.rsapps.net ([])
	by backend48.mail.iad3b.rsapps.net (Dovecot) with LMTP id NNN3CimlOVssEwAAfQzJJw
	for <alex.kucheryuk@eltoma-offshore.com>; Mon, 02 Jul 2018 00:08:09 -0400
Received: from proxy7.mail.iad3a.rsapps.net ([])
	by director10.mail.iad3b.rsapps.net (Dovecot) with LMTP id Gy0iDymlOVvaLQAA+q2Skg
	; Mon, 02 Jul 2018 00:08:09 -0400
Received: from smtp25.gate.iad3a ([])
	(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
	by proxy7.mail.iad3a.rsapps.net with LMTP id ALAoLCmlOVt0MgAAnPvY+A
	; Mon, 02 Jul 2018 00:08:09 -0400
Return-Path: <olga@eltoma-dev.com>
X-Spam-Threshold: 95
X-Spam-Score: 0
X-Spam-Flag: NO
X-Virus-Scanned: OK
X-Orig-To: alexander.kucheryuk@eltoma-global.com
X-Originating-Ip: []
Authentication-Results: smtp25.gate.iad3a.rsapps.net; iprev=pass policy.iprev=""; spf=pass smtp.mailfrom="olga@eltoma-dev.com" smtp.helo="elt.eltoma-cyprus.com"; dkim=pass header.d=eltoma-dev.com; dmarc=none (p=nil; dis=none) header.from=eltoma-dev.com
X-Suspicious-Flag: NO
X-Classification-ID: 87204ff8-7dad-11e8-b5a7-52540086a678-1-1
Received: from [] ([] helo=elt.eltoma-cyprus.com)
	by smtp25.gate.iad3a.rsapps.net (envelope-from <olga@eltoma-dev.com>)
	(ecelerity r(Core: with ESMTPS (cipher=DHE-RSA-AES256-GCM-SHA384) 
	id 51/44-18843-925A93B5; Mon, 02 Jul 2018 00:08:09 -0400
DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed;
	d=eltoma-dev.com; s=default; h=Message-ID:Subject:To:From:Date:
	 bh=g3zLYH4xKxcPrHOD18z9YfpQcnk/GaJedfustWU5uGs=; b=vkWI5uryXXcm8UfGJLVyYWaTw
Received: from [] (port=36076 helo=elt.eltoma-cyprus.com)
	by elt.eltoma-cyprus.com with esmtpa (Exim 4.91)
	(envelope-from <olga@eltoma-dev.com>)
	id 1fZq8G-0002Ot-2o
	for alexander.kucheryuk@eltoma-global.com; Sun, 01 Jul 2018 23:08:08 -0500
MIME-Version: 1.0
Content-Type: text/plain; charset=US-ASCII;
Content-Transfer-Encoding: 7bit
Date: Sun, 01 Jul 2018 23:08:07 -0500
From: olga@eltoma-dev.com
To: alexander.kucheryuk@eltoma-global.com
Subject: test
Message-ID: <4cc55620bb18c1d8ec97243c15dffed3@eltoma-dev.com>
X-Sender: olga@eltoma-dev.com
User-Agent: Roundcube Webmail/1.3.3
X-AntiAbuse: This header was added to track abuse, please include it with any abuse report
X-AntiAbuse: Primary Hostname - elt.eltoma-cyprus.com
X-AntiAbuse: Original Domain - eltoma-global.com
X-AntiAbuse: Originator/Caller UID/GID - [47 12] / [47 12]
X-AntiAbuse: Sender Address Domain - eltoma-dev.com
X-Get-Message-Sender-Via: elt.eltoma-cyprus.com: authenticated_id: olga@eltoma-dev.com
X-Authenticated-Sender: elt.eltoma-cyprus.com: olga@eltoma-dev.com


I have added the entire (raw) source of the email. “Test” is the message body. I have sent this email from the same mailbox as the one Zammad was receiving from the same client (webmail). The only exception is that this email was addressed to my email client (as opposed to sending it to Zammad).

Thanks for the Code. Couldn’t find any fishy in those headers. Thus, I searched the github repo for the String you receive - this is the code part that throws it:

local_send_notification = true
    if article && send_notification == false && trigger.perform['notification.email'] && trigger.perform['notification.email']['recipient']
      recipient = trigger.perform['notification.email']['recipient']
      local_send_notification = false
      local_options[:send_notification] = false
      if recipient.include?('ticket_customer') || recipient.include?('article_last_sender')
        logger.info { "Skip trigger (#{trigger.name}/#{trigger.id}) because sender do not want to get auto responder for object (Ticket/#{ticket.id}/Article/#{article.id})" }

( https://github.com/zammad/zammad/blob/0dbfcd0edfc3082b7e2932b4b9ecfdb8c5ff9f8b/app/models/ticket.rb#L1239 )

Not sure if I get it right, but I think that the user has disabled the notification for the queue or whole system.

Maybe @thorsteneckel could enlight me here (I’m not a dev after all hehe)

Hi @alex2407,

I think it’s caused by this line:

Is your FQDN Setting set to eltoma-dev.com? Because Zammad will skip mails with a message ID containing the FQDN. This is the case for messages send by the system itself. So it will prevent endless loops of sending messages from and to the same system.

Correct, my email queue is set to accounting@eltoma-dev.com and FQDN is set to eltoma-dev.com. I see why this happens. I have the following question then:

How can I have queue and agents and Zammad use the same domain?

I have the following scenario:

I need to create internal ticketing system for accounting department (that will later be expanded to other departments as well). I want to be able to use accounting@eltoma-dev.com as the email for the queue and have agents (e.g. agent1@eltoma-dev.com, agent2@eltoma-dev.com, etc. receive emails when the user, another agent from the same domain replies). The reason why I changed FQDN to eltoma-dev.com is that notification emails use FQDN i.e. noreply@FQDN.

Hi @alex2407 - you can define a Postmaster Filter (Admin -> Email -> Filter) which allows you to change the (Expert -> ) Ignore flag for incoming mails. Note that this is currently broken in the develop branch but we’re working on a fix. However, stable should work fine :+1:

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.