Auto-Reply on new ticket doesn't work

Hi,

I dont know why but auto-reply on new tickets doesn’t work anymore.
I already degraded the trigger to the minimum, but it still doesn’t send a reply.


(also tested with “article last sender” instead of customer")

any idea why? i dont even see the trigger after the article, but it’s working for other triggers, like customer notification on owner change

zammad 2.9.x via package on ubuntu

Did you by any chance add a new group where you experience this issue or remove a mail address?
Ensure that you can reply to tickets in the group via mail, where Zammad is not able to send notifications.

Also take a look into your production.log, it might hold hints on what’s wrong.

Please note that you need to set email addresses for triggers within your groups:
https://admin-docs.zammad.org/en/latest/manage-groups.html

Other than that, your trigger looks perfectly fine and should fire.
Maybe a look into your ticket history of affected tickets helps too.

By default new Tickets hat the Group “Nicht zugewiesen” (not assigned), I’ve tested with and without assigning a mail to the group as advised in other tickets.


(I have only one mail in zammad)

production.log show this: I, [2019-11-21T13:41:57.975347 #11702-46998715404520] INFO -- : Skip trigger (Auto-Reply (Neues Ticket)/9) because sender do not want to get auto responder for object (Ticket/1366/Article/5826)

What the hell? Where is that option set? I’ve even created new mail accounts to test this, and all of them have this option… That explains why no mail is sent, but I don’t get what this option is.


I’ve seen this "Skip trigger (#{trigger.name}/#{trigger.id}) because sender do not want to get auto responder for object (Ticket/#{ticket.id}/Article/#{article.id})" but for me it doesn’t work on ALL mails, it doesn’t matter where they come from, gmail, yahoo etc.pp. all are affected.

E-Mail is required for a group to send trigger based mails.
However, as you named it “nicht zugewiesen” I’m not sure if you’re mixing things up, because it smells like you want it to be a overview like a “folder” in your outlook.

If this is the case, you might want to check out our overviews:
https://admin-docs.zammad.org/en/latest/manage-overviews.html

Please provide more input.
Zammad ignores mails that it detects as being auto generated or submitted.
This also affects mailing list mails or distribution list within Exchange.

We had this topic one or two weeks earlier, if you’re interested in why and how this happens, you can take a look at this article:

Further up in the above thread you can find a eml of the user that shows where to look at.

1 Like

Okay I’ve found the issue now.
When starting to use zammad we had the mail account support@test.example.org - after switching to production use we kept that account, and just forward any incoming mail to support@example.org to support@test.example.org

Both domains are on different mailservers, but both have the same domain (mailserver1.example.org & mailserver2.example.org) - I guess thats why this happens.

I think I’ll have to enable IMAP on one mailserver then and use the support@example.org mailbox directly.

1 Like

Please note that direct forwarding does not work, a working alternative is bouncing the mail (or moving the mail affected into a folder Zammad fetches). :slight_smile:
Glad you found the issue.

okay, unfortunately enabling imap on exchange is not an option for me.

what do you mean by bouncing the mail? is it possible to bounce a mail which was sent to an exchange mailbox to another non-exchange mailbox which is not the sender?

Sorry but this as far as I can help you.
Zammad can’t use ActiveSync and required POP3 or IMAP, depending on what you need to do.
You can find further information on bouncing here:

and here (you want to redirect):

Well that’s exactly what I do, but both mail servers are on the domain *.example.org, thats why the trigger is not working

is there a way to disable this Skip trigger rule?

There is a great technical difference between forwarding (Weiterleiten) and redirecting (umleiten).

It will not work -at any point- with forwarding, you need to redirect!
Sorry, but this is a mail server dedicated issue we / I can’t help with.

I understand but as zammad decides to skip the trigger there should be an option to disable this function right?

It technically is possible, however, we do not encourage you to do so.
Anyway, if you still want to do it, please take a look at this thread:

I had a similar issue where Auto-reply on new tickets doesn’t work.
The issue was that I had set up the Email Notification using sendmail protocol for sending emails, which was not working.

See the Email Notification settings in the screenshot below:

Here’s how Is olved it:

I simply had to edit by clicking the Edit button by the side and then changing the protocol to SMTP, which enabled me to setup up the SMTP host, email, password, and port.

See the Email Notification settings in the screenshot below:

Hello!

I started using zammad today, and I setup the system with 3 groups (eg: Sales, Support, Finance), and I already have groups for then on my company.

I use G-suite, and it is pretty expensive (at least at my currency :stuck_out_tongue: ) to have an account just for IMAP and nothing else, so my setup was:

Use the g-suite groups to “redirect” the same IMAP account. When the email get received by the account, use the filter to Skip Inbox, and place it into the correct folder.

On zammad, I configured 3 times the same account, but each time on a different folder (I moved manually the email, but I don’t notice if this is necessary or not yet)

I was getting almost crazy because I (as a client) was not receiving the emails, no matter what I set as a trigger rule. At first I thought it was some issue on filter, but the filter was working, but still, i removed.

I was able to make it work now by deleting the setting on the table, but I think this rule is kinda important, and should be kept (and I also don’t know if db:migrate would repopulate this on further deploys, I restarted the containers and the setting was not added so far)

I think the safe option is to add another setting where Channel::Filter::AutoResponseCheck check for a regex of allowed lists and return early without testing any other setting.

I want your feedback if this would be merged back if I opened a pull request.

I also am open for other options for cheaper imap providers or other strategies for this situation.

thank you

I was able to make it work now by deleting the setting on the table, but I think this rule is kinda important,

What specifically did you do here?

I got same issue, when adding the support address to a google group, the autoreply New Ticket doesn’t get triggered.

The autoreply only get triggered when I send to that address directly. In both case a ticket is actually created and I can respond to the original sender.

I for one would be interested in your PR :smile:

EDIT: I just solved it for my case, not sure if it was the same as yours. Following the lead from above that forwarding doesn’t work, redirect is needed, I found and followed this: https://support.google.com/a/answer/4524505
Now it works as I hoped. Zammad is awesome

Please, for the next time, don’t mix up topics too much. Getting quite complicated to follow to be honest.

Oma is correct - you should never ever forward a mail to Zammad, but instead redirect / bounce it.
Reason for that is that usually a forward also removes the original headers which ends in Zammad not being able to find out who the original sender was.