Emails Sent via the Scheduler Don't appear On The Ticket?

Infos:

  • Used Zammad version: 3.2.x
  • Used Zammad installation source: apt package
  • Operating system: Ubuntu 18.04 LTS
  • Browser + version: n/a

Expected behavior:

  • When the Scheduler sends an email, the email shows up on the relevant ticket for documentation purposes.

Actual behavior:

  • An innocuous bit of text displays in it’s place in the format

"[name of scheduler job]" => "[to email address]"

Steps to reproduce the behavior:

  • Set up a scheduler job to send an email on a ticket. The settings I used are:
    • When should the job run? Every 10 minutes
    • Conditions for effected objects
      • Tags: contains one: [tag on a ticket]
      • Created at: within last (relative): 5: Day(s)
    • Execute changes on objects:
      • Email to “customer”
    • Disable notifications: yes
    • Note: null
    • Active: active

I might be confused about how the scheduler works. What I am trying to accomplish is to create an email campaign of sorts. One of the products we sell requires that we set up a series of emails to our client that fire off at specific times - e.g. once a month. My theory was that we would create a ticket and tag it. Then the scheduler would fire off an email based on the tag and the ticket created time.

However, the system breaks down if the email doesn’t show up on the ticket, because we have no record of what we actually sent the client (the contents of the email in the Scheduler might change over time). Is there a way to accomplish this?

The emails scheduler sends are notifications only, hence they won’t get added to the ticket. (You’ll see a one-liner showing that an e-mail notification has been sent and the address it got sent to.)

Let’s hope the team will add the option to also add e-mail or phone articles (not just notes) to tickets!:metal:t2:

A feature request on this board would be a start for that. :wink:

I never realized that emails sent via the scheduler were supposed to be notifications - that isn’t clear from the interface, which just says “Email” when you select it. Also, the “notification” itself is an email that accepts anything in the body anyway. The way it works doesn’t match the interface IMO.

On a related topic, I think that scheduler emails should be added in their entirety to the thread anyway (look and feel can be different, if that is desired), because the one-liner isn’t enough to know what was sent. System notifications have a set purpose and can’t be deleted, so one-liners are fine to indicate they were sent. When you create and delete your own custom notification you need a record of what was actually sent for the record.

While I understand your point of view, I personally don’t see the use.
That is, because many Zammad users use schedulers and triggers to send automated mails - many of them in a bit more frequent manner which simply could fill the ticket with articles and thus worsen the overview.

Any way, a feature request on this board would be ideal to find out what the rest does think! :slight_smile:

Done :slight_smile:

I think this could be solved in two ways:
• Add scheduler/trigger notifications full-text to the ticket view (if I’m right the articles in the database contain the full text, so this should be a small change within the view only)
• Add ‘real’ e-mails to triggers/scheduler—i.e. notifications would work the way they did before

I’m with you when it comes to the typical use case of notifications—why should they appear in the ticket?—but then again I’m desperately waiting for the aforementioned addition anyways :slightly_smiling_face:

Well if I’d have the choice to not blow up options too much, a tick or dropdown “also display article content in ticket view” would be a good approach. No clue how much effort this takes though.

1 Like