E-Mail Signature with PNG Pictures and mailto Links (HTML)


Docker-compose version: docker-compose version 1.27.4
Operating system (Docker host): Ubuntu 20.04

Expected behavior:

e-mail -> signatur edit

Steps to reproduce the behavior:

I have insert my logo (PNG File) like this instructions here ( Email Signatures Pictures ).

My png logo have a transparent background. after inserting it into zammad (edit signature) the image has a black background. and the logo can no longer be recognized correctly. is there currently no other way to add the logo in a signature?

Unfortunately, no mailto links are recognized in the signature, even if these are inserted in html format. can the signature be formatted in html at all?

See screenshot from my “test logo” background is black in Zammad but why?

The image possibly is converted to jpeg - probably by your browser.
Quick workaround would be to provide an image with a fitting background color.

As for your mailto issue, this is currently technically not possible.
This will be fixed with Zammad 3.7 - see: Allow mailto links in knowledge base (KB) and email signatures. · Issue #3344 · zammad/zammad · GitHub

1 Like

I have a jpeg with blank background but why the browser convert it? Any option to use my png file? Because on mobile devices with dark mode email not look nice.

Is there same plane to use WYSIWYG for ticket reply and signatur options?

Any release date about 3.7?

A transparent jpeg? Never seen that.
But neither than less. We do not have any power over what the Browser does from your clipboard to the insert. If it decides that transparent backgrounds suck (don’t get me wrong :wink: ) we won’t have much power on that.

So at that point I’m afraid you can’t do anything.

The backend editor and frontend one are actually exact the same already.
Please understand that I can’t and won’t forecast possible functions of the future and the way they might work.

We in general do not communicate ETAs. Not for issue fixes nor releases.

I can get a PNG with a transparent background in, but it only works some of the time for no apparent reason (getting it into the signature that is - once the image is there, it stays there).

Use Firefox (doesn’t seem to work in Chrome), drag the image file from windows explorer into the signature panel (no copy and paste). Have a little patience, and swap between having the browser in the foreground and the explorer in the foreground as that seems to nudge it towards working sometimes. Move the cursor around in the signature box if it’s not working, any little change could get it to catch on

I presume blank as in white, not transparent. You’re right though, jpg doesn’t support transparency.

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.