Upgrade from 6.2 to 6.3 failed

Infos:

  • Used Zammad version: 6.2.0-1712728678.1fb595f2.bookworm
  • Used Zammad installation type: package
  • Operating system: Debian GNU/Linux 12 (bookworm)

Expected behavior:

Zammad version changing from 6.2 to 6.3

Actual behavior:

Apt fails to install / update the package “zammad”

Steps to reproduce the behavior:

systemctl stop zammad
/opt/zammad/contrib/backup/zammad_backup.sh
zammad run rails r "Rails.cache.clear"
apt update
apt upgrade

I’m trying to update the package version of Zammad from 6.2 to 6.3, at the end of the “apt upgrade” process, I see…

Errors were encountered while processing:
 /tmp/apt-dpkg-install-onGGSF/37-zammad_6.3.1-1720156707.17f20fad.bookworm_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

The dpkg log looks like it’s claiming zammad is installed, but I can’t reach it’s webui anymore after doing the steps above.

2024-07-08 08:08:12 upgrade zammad:amd64 6.2.0-1712728678.1fb595f2.bookworm 6.3.1-1720156707.17f20fad.bookworm
2024-07-08 08:08:12 status half-configured zammad:amd64 6.2.0-1712728678.1fb595f2.bookworm
2024-07-08 08:08:12 status unpacked zammad:amd64 6.2.0-1712728678.1fb595f2.bookworm
2024-07-08 08:08:12 status half-installed zammad:amd64 6.2.0-1712728678.1fb595f2.bookworm
2024-07-08 08:08:13 status unpacked zammad:amd64 6.2.0-1712728678.1fb595f2.bookworm
2024-07-08 08:08:48 status installed zammad:amd64 6.2.0-1712728678.1fb595f2.bookworm

I also tried the solution in this thread, which mentioned using the -f flag for apt, this causes the package to “successfully install”, however, I then get stuck at a Zammad branded 500 page with the Zammad bird in a birdhouse.

Ye got the same problem here :frowning:

Did you also get an elasticsearch update?

Indicates the installer stopped. Our pre install does provide a feedback output in your console which should be higher.

If I’d have to guess: Your database server was not available during upgrade.

This was one of the things that showed up I think yes.

Still not fixed from the bug that was preventing upgrade of 6.0 to 6.1?

You’re supposed to upgrade Zammad without upgrading your database server at the same time. The thing that changed is that the process is telling you that you’ve been a “bad boy” by ignoring this.

Then what is the procedure?

The database is on the same machine :slight_smile:

  • Verify that your database server has no update open
  • -if- stop Zammad and update the database server directly and start Zammad after
  • Apply the rest of the updates

How that’s done depends on your OS at some points. As you’re administering it - you’ll know better than me most likely.

Thank you, I changed the procedure I was following to…

systemctl stop zammad
/opt/zammad/contrib/backup/zammad_backup.sh
zammad run rails r "Rails.cache.clear"
apt-mark hold zammad
apt update
apt upgrade
apt-mark unhold zammad
apt update
apt upgrade

…so that way I was upgrading “everything else”, and the second upgrade did only the zammad package, which resolved my issue.

It was my first upgrade that didn’t “just work” so I was caught by surprise here and wouldn’t have expected it to care about the other 60 or so packages that had upgrades available since I last apt update && apt upgrade a couple weeks ago.

2 Likes

I will give this a try this evening :slight_smile:

Thank you

This worked :slight_smile:

Thank you

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.