Unable to process GET request to elasticsearch


Expected behavior:

Elastic Search Does not work

Actual behavior:

{“error”:“Unable to process GET request to elasticsearch URL ‘’. Elasticsearch is not reachable, probably because it’s not running or even installed.\n\nResponse:\n#\u003cUserAgent::Result:0x00007f07b8655ad8 @success=false, @body=nil, @data=nil, @code=0, @content_type=nil, @error=”#\u003cErrno::ECONNREFUSED: Failed to open TCP connection to (Connection refused - connect(2) for \“\” port 9200)\u003e"\u003e\n\nPayload:\n{:query=\u003e{:bool=\u003e{:must=\u003e[{:range=\u003e{“created_at”=\u003e{:from=\u003e"2018-12-31T21:00:00Z", :to=\u003e"2019-12-31T20:59:59Z"}}}], :must_not=\u003e[{:term=\u003e{“state”=\u003e"merged"}}]}}, :size=\u003e0, :aggs=\u003e{:time_buckets=\u003e{:date_histogram=\u003e{:field=\u003e"created_at", :interval=\u003e"month", :time_zone=\u003e"Europe/Istanbul"}}}}\n\nPayload size: 0M"}

i came here from Unable to process GET request to elasticsearch URL ''

i did the same things but no it is doesnt work, can you help please.

Sorry, but fix your elasticsearch configuration.
Is it intentional that you’re trying to talk to another host?

If so, ensure your elasticsearch is reachable from that address.
This is out of scope for us.

Edit: Another note: This is a potential security risk if you a have strangers on your net or point ES to the internet. :-X

Thank you for reply,
Elasticsearch and zammad are on the same device, they do not talk to each other from different hosts.
Elasticsearch is active an working.

zammad is working

Everything is working but zammad can not use elasticsearch

As @MrGeneration already said, you probably didn’t configure elasticsearch/zammad the proper way.

You even linked the thread with the proper solution to the problem you’re reffering to:

The documentation you used also states something you most likely didn’t do:

Next, you will need to make Zammad work with Elasticsearch and rebuild index. You can do it with the following command:

zammad run rails r "Setting.set('es_url', 'http://localhost:9200')"
zammad run rake searchindex:rebuild

Please have a look at the official documentation and make sure you did everything as stated there:


Thanks for reply,
i believe i configured them correctly, yes i linked the solutions and i said i did what is suggested, but no hope; image .

Seems like problem is solved after i restarted Ubuntu host.

The above is the reason why I assume that you’re trying to talk to a different elasticsearch.


Actually i did not, after restart problem solved, maybe firewall blocked something. but now zammad is deleted automatically after i deleted elasticsearch (i didnt know elasticsearch will delete zammad) :frowning: all my problems droped for now :frowning:

thank you.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.