Unable to add Microsoft 365 Accounts in Zammad

Infos:

  • Used Zammad version: 5.2.x
  • Used Zammad installation type: docker-compose
  • Operating system:
  • Browser + version: Google Chrome Version 108.0.5359.125

Expected behavior:

Giving once the permission to the enterprise application in azure so that it isn’t needed to do, more then once for an application.
*

Actual behavior:

We have the same error as the two people already reported in 2020 and 2022 with the error: Can't connect to MS365 Account - #2 by benmo and Unable to add Microsoft 365 account when admin consent for enterprise applications is enabled · Issue #3963 · zammad/zammad · GitHub
Did you ever found a workaround to fix this? It seems to be open since two years.

We gave admin consent to the application in Azure and we have been able adding users in zammad, when we had the toggle switched off that Users can give consent to applications. Unfortunately, since we turned that of (for the known reasons), it’s impossible to add new users in zammad. Is there a way to give admin consent just once to the application?


Thank you in advance for any help.

kind regards

Steps to reproduce the behavior:

Disable the requirement for admin consent until after you have setup the accounts. I couldn’t get it to work otherwise in my environment.

Thank you @Sal for your quick help. In this case we will enable and disable it when we add new accounts.
Sad to hear that there isn’t any other solution. Do we know if anything is planned for it?

Zammad does support admin consent since late 5.2.
Apart from updating to 5.3.1 not hurting at all, if your patch level fits the UI will show.

Following the documentation for on this will actually do the trick. Note that your Microsoft App needs specific settings.

That’s good to know. We originally set things prior to 5.2.