Triggers with multiple conditions - workaround?

Infos:

  • Used Zammad version: 3.4
  • Used Zammad installation source: package
  • Operating system: Ubuntu
  • Browser + version: Firefox 82

Expected behavior:

  • Do not send auto-reply for more than one specific user.

Actual behavior:

  • It is not possible to specify a trigger using the same client (“Kunde”) multiple times

Steps to reproduce the behavior:

  • In a trigger, specify a condition using “Kunde”, “is not” and a specific mail address
  • Try to specify another condition using “Kunde” to suppress auto-reply for a second mail address. “Kunde” is greyed out.

As already described in the github ticket 2185 (https://github.com/zammad/zammad/issues/2185) and in this forum (Trigger - Conditions with multiple inputs), this is currently not possible in Zammad.
Therefore, do you have an idea to work around this using the current Zammad version?

Currently we have one mail address specifically configured to not receive an “auto-reply” (because it is not a person but a computer system which cannot handle the mail). We would like to add another mail address as a second exception, because it is a computer system as well.
Since it does not work the way described above, can anyone suggest a creative way of getting this to work using the current capabilities of Zammad?

Thanks in advance!

1 Like

If you don’t want to send auto replies to specific users that you can’t reduce to an alias (if you could Block notifications could help https://admin-docs.zammad.org/en/latest/channels/email/settings.html ) you’ll have to use an custom object.

Either use boolean or select and allow your agents to set it to false if the user complains about those notifications. Ensure to add the custom field as condition to the triggers in question and ensure that the value of the object is not e.g. false and you’re ready to go.

This reduces administrative work and removes possible clusterfucks of 100s mail addresses in a trigger.
Even if we do allow AND/OR later on, above is the suggestion to go in my opinion.

Hello, “block notifications” works great :slight_smile: Consequently, I could modify the existing “auto-reply” trigger so that it doesn’t need to take care of that any more. And for the second address it will also work, but I did not yet configure this.

Thanks a lot!