[solved] File button to show all attached files in a ticket

If a ticket gets longer you have to scroll trough the whole ticket to find attached files.

It would be nice to have a button which shows all files attached to a ticket.

e.g.
image

1 Like

mhm.
Maybe run zammad run rails r "Setting.set('ui_ticket_zoom_sidebar_article_attachments', true)" restart Zammad and be happy.

7 Likes

thank you Marcel - that was exactly the thing I was looking for.

I’m trying to run this, but it seems i don’t have this setting. The settings seems to be introduced in zammad/20180220000001_setting_attachment_preview.rb at 5df98684da64aed93cc29e4be029d81566520906 · zammad/zammad · GitHub. While i’m still at zammad version 3.6.X, i would expect it to be available. Also checking the settings table i don’t see any setting with that name. Am i missing something obvious?

zammad@75f4b85b4fbf:~$ rails r “Setting.set(‘ui_ticket_zoom_sidebar_article_attachments’, true)”
Traceback (most recent call last):
18: from bin/rails:9:in <main>' 17: from /usr/local/bundle/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:291:in require’
16: from /usr/local/bundle/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:257:in load_dependency' 15: from /usr/local/bundle/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:291:in block in require’
14: from /usr/local/bundle/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:29:in require' 13: from /usr/local/bundle/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:20:in require_with_bootsnap_lfi’
12: from /usr/local/bundle/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/loaded_features_index.rb:65:in register' 11: from /usr/local/bundle/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in block in require_with_bootsnap_lfi’
10: from /usr/local/bundle/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in require' 9: from /usr/local/bundle/gems/railties-5.2.4.5/lib/rails/commands.rb:18:in
8: from /usr/local/bundle/gems/railties-5.2.4.5/lib/rails/command.rb:46:in invoke' 7: from /usr/local/bundle/gems/railties-5.2.4.5/lib/rails/command/base.rb:69:in perform’
6: from /usr/local/bundle/gems/thor-1.1.0/lib/thor.rb:392:in dispatch' 5: from /usr/local/bundle/gems/thor-1.1.0/lib/thor/invocation.rb:127:in invoke_command’
4: from /usr/local/bundle/gems/thor-1.1.0/lib/thor/command.rb:27:in run' 3: from /usr/local/bundle/gems/railties-5.2.4.5/lib/rails/commands/runner/runner_command.rb:41:in perform’
2: from /usr/local/bundle/gems/railties-5.2.4.5/lib/rails/commands/runner/runner_command.rb:41:in eval' 1: from /usr/local/bundle/gems/railties-5.2.4.5/lib/rails/commands/runner/runner_command.rb:41:in
/opt/zammad/app/models/setting.rb:37:in `set’: Can’t find config setting ‘ui_ticket_zoom_sidebar_article_attachments’ (RuntimeError)

Thanks Olaf

Yeah, well most probably any important migrations that did not run.
That’s the only reason why these settings may be missing. that functionality is fairly old (pre 3.0)

1 Like

would running “rake db:migrate:up VERSION=20180220000001” do trick, or should i run these important migrations in another way?

1 Like

awsome running the migration did the trick, the feature works great. Thanks!

How have I never even heard of this setting before? I can’t find any mention of this in the docs, I can’t find any GUI setting for this in Zammad. Should this be in the GUI? I only started with Zammad in the end of 2019 so I can’t have missed any migrations. In your response to the original question you make it sound like this setting should be common knowledge but it’s obviously very well hidden and could be communicated better if you ask me.

This has been a hidden settings ever since.
The requirement of this functionality is fairly low.

We try to keep Zammads settings as slim as possible when ever possible. Said setting is such a case.

You can only set it via console currently is the only way. Not sure if it’s currently living in the console documentation - that one needs rework any way so…