Nextcloud as OAuth2 Provider not working (Minimum one identifier (login, firstname, lastname, phone or email) for user is required.)

Infos:

  • Used Zammad version: 3.2.x
  • Used Zammad installation source: package
  • Operating system: Ubuntu Server 18
  • Browser + version: Firefox / Safari latest

Expected behavior:

  • Setting up Nextcloud as OAuth2 provider in Zammad
  • be able to login

Actual behavior:

  • When trying to log in with OAuth2, I’m getting “422: Minimum one identifier (login, firstname, lastname, phone or email) for user is required.”

Steps to reproduce the behavior:

  • Setup OAuth2 with nextcloud and zammad

Can you please let me know at what point in the Zammad settings you’re trying to achieve oAuth authentication? There are several points where this technically might be possible, I just want to ensure we’re talking about the same part. :slight_smile:

I’m trying to set up OAuth2 for login under Settings->Security->Third-party Applications.

I see, thank you!
The gerneric oAuth2 authentication currently is, as far as I’m aware not usable at any point.

@thorsteneckel might however correct me.

What @MrGeneration said. We had a technical misunderstanding on the module we are using and OAuth2 is not as Generic as we expected it to be. There is always the need of writing custom code - unfortunately.

Hello timtim8461,

Did you manage to get oauth2 authentication to work with nextcloud please ?
And if so how did you proceed ?

@ludovicis no, sadly not. In the moment I don’t have much time to look on that. Maybe I will find some time in a few week to try to implement this.
But would be great to get native nextcloud support for zammad @thorsteneckel!

1 Like

@timtim8461 Please create a feature request on this board to help us evaluate the need of this functionality. :slight_smile:

1 Like

Hello,

Feature request create

1 Like

Just for reference if anybody is searching for it:

:slight_smile: