Login not possible "Error ID XYZ" but login already worked

Infos:

  • Used Zammad version: 3.3.0
  • Used Zammad installation source: Docker with Traefik
  • Operating system: Docker
  • Browser + version: FF + Google Chrome

hi Guys

I have successfully run Zammad with Traefik in Docker.

After a few small mistakes I was able to solve them.

Most recently I had successfully logged on to 3 computers and was able to work well.

Yesterday I wanted to activate an additional agent and changed his password (user had been created for a long time) and logged out and wanted to log in as a test agent.

Only get the error message “Error ID” and no login possible.
Even as “admin” I can no longer log in.

What could you do? Nothing is logged in the logs under / var / log / ngnix.

I also had the ES read in again.
Still no improvement

I think the Error ID is related to the CSRF.
What can I do to get this under control?

Please check your production.log to find out what the error really is about. Let’s not fish in the dark. :slight_smile:

grep "Error ID xyz" /var/log/zammad/production.log

Please also note that while some users do use Traefik, we do not officially support it and thus cannot help you in a sufficient way. Other community users might be able to help you though.

I would like to give it to you. But neither in the volume of the DockerContainer Zammad-Data nor anywhere else can I find a Production.log file.

Otherwise I would give it to you already!
I use the Docker Compose directly from you.

I have now found the logs via Portainer

E, [2020-03-20T13:07:11.572948 #1-47086467150300] ERROR – : Error ID nRnF1mc-: CSRF token verification failed!
E, [2020-03-20T13:07:11.573132 #1-47086467150300] ERROR – : Error ID RJByeUrx: CSRF token verification failed!

Please see this post:

point 2.1 should help you

@csaeum Would you mind sharing your Traefik configuration ?

See here: