LDAP Sync won't stop


  • Used Zammad version: latest
  • Used Zammad installation type: source
  • Operating system: Ubuntu 20.04
  • Browser + version: Chrom

Expected behavior:

  • LDAP Integration has worked

Actual behavior:

The process does not go on, gets stuck in one place:

Steps to reproduce the behavior:

  • Install Zammad, migrate data from OTRS, try to configure LDAP Integration.

Production Log:

From the symptoms this looks similar to my old LDAP Configuration "Counting entries. This may take a while" never ends which unfortunately was never solved. We never managed to integrate Zammad into LDAP @work. I’m curious, if this time a solution pops up :smile:

Hey, thanks.
That is it, I waited for an about one hour but it didn’t stop. I had to destroy the job via rails and tried to configure LDAP Sync again and again with another settings but it didn’t work no matter what I did.
It’s very sad, I would like to implement Zammad at my workplace, but there are so many problems.

What kind of LDAP server do you use?

Do you have a lot of users in there? Say, more than 50k?

Are the values for Base DN and UID correct?

Windows 2012R2

Not a lot: over 900 but less then 1000

Yes, during configuration, the server is recognised correctly, the data about OUs and groups is also recognised correctly.

Oh, I haven’t seen one of those since several years.
Maybe someone else here has this combination up and running?

It’s not my decision, I am just a trainee :wink:

I’ve installed Zammad one more time, this time via package. The migrate from OTRS was faster. And then I was able to integrate LDAP. I’ve used another DC-server, Windows 2016 and ist has worked without any problems.
I don’t know it was because of installation via package or of another server OS but the idea for another DC-server was very good. Thank you @TomGem !

Good to hear @Irina ! :+1:

lucky @irina :slight_smile: It still doesn’t work for us. I’ll have to check if there alternative domain controllers available…