Knowlegde Base not activating

Hi,

I am very exited about the knowledge base funktionality.
Thank you very much for this.

So I just updated to V3.

Unfortunately I can not activate the Knowledge Base:

I click the Button and it turns blue.
When I switch to another Menu and get back to the knowlegde base, it is deactivated again.

Is there anything I could search for in the logs.
Where can I find the logs?

1 Like

Hi,

we have the same Problem here.

Had same issue. Try logging out of zammad, clear browser cache, close it, reopen browser, log in to Zammad and go directly to Settings -> Knowledge Base. Activation should work.

My browser: Firefox

Unfortunately not working for me
I tried different browsers now, but no success

Problem still exists. Wiped everything in my Firefox.

https://community.zammad.org/t/asking-for-help-on-community/2262/2

We can’t help you at the current information provided.

I just updated to v3
yes great, from where?

Installation type etc etc
Why is this so hard?!

Hi,

we updated from 2.9 to 3 via apt-get upgrade on debian

Database: I don’t know. Where can I find this information?
Elasticsearch version: 5.6.16
Browser being used: Firefox, Chrome, Edge

What further information do you need?

As I said, I would love to search for the log, but i don’t find them

I think I found the Log file in /var/log/zammad/production.log

There is an interesting part in it:

I, [2019-06-07T14:46:45.939620 #425-69901371146260] INFO – : Processing by KnowledgeBase::ManageController#init as JSON
I, [2019-06-07T14:46:45.939677 #425-69901371146260] INFO – : Parameters: {"_"=>“1559911236338”}
E, [2019-06-07T14:46:45.946228 #425-69901371146260] ERROR – : PG::UndefinedTable: ERROR: relation “knowledge_bases” does not exist
LINE 1: SELECT “knowledge_bases”.* FROM “knowledge_bases” ORDER BY …
^
: SELECT “knowledge_bases”.* FROM “knowledge_bases” ORDER BY “knowledge_bases”.“id” ASC LIMIT $1 (ActiveRecord::StatementInvalid)

Does that help you?
It seems the database could not be updated properly

That’s correctly. Normally the database gets updates with upgrading the Zammad package.

In your case it seems that this was not done my the deb-package.

You can do this manually by executing:

zammad run rake db:migrate

Restart Zammad and then all should work fine.

Feedback is welcome.

1 Like

That worked! Thank you so much!

1 Like