Knowledge Base - As User?


  • Used Zammad version: 5.3.1-1677147662.62001c62
  • Used Zammad installation type: Package, Ubuntu 20.04

Actual behavior:

As User I cant see the knowledge base and I dont get recommendations if I use a key word (tag)

My view:

User View:

Go to the admin panel > roles and grant the role Customer the permission for knowledge base (reader).

Thanks !!! :slight_smile: Guess I am blind :smiley:

1 Like

The reader’s permission is only needed for “internal” answers. To see “public” answers, no permissions are needed.


Just a note or suggestion regarding this option:

We had the same problem and initially had difficulty finding the right setting. As we only have internal users, we only use the internal knowledge base, as we do not want to put our documentation on the internet publicly.

We were somewhat confused by the description of the option. It says “Manage Knowledge Base Reader”. It was unclear to us whether this role allows the affected users to manage the knowledge base readers or whether it is only about the authorisation to read the knowledge base.

Perhaps the description could be adapted. Something like “Grant read access to the internal knowledge base”.

Should I open a Github issue on this? Or can I submit this proposal in another way?

Thank you.

That is a great suggestion to rename that phrasing @Speedy-Gonzalez . Can you please create a Feature Request for that?

I’d make one small change suggestion though: “Grant read access to internal knowledge base answers”.



I have now created the feature request.

1 Like