Integration Facebook error

Infos:

  • Used Zammad version: newest
  • Used Zammad installation source: (source, package, …) package
  • Operating system: Debian
  • Browser + version: no difference

Expected behavior:

  • App gets connected and I can select a page

Actual behavior:

Steps to reproduce the behavior:

  • Set up a facebook app and connect it with zammad

I think there will be an update to the Facebook integration in the next Zammad version. In the meantime, you may want to use this workaround:

  • Configure your app according to the documentation. Make sure you select “Manage business integrations” as your app type.
  • Add the Facebook Login to your app, set it up according to the docs
  • When everything is ready, fill in your app information in Zammad
  • Press the “Add Account” button
  • You’ll end up on a page with an error message: Invalid Scopes: publish_pages, manage_pages
  • Edit the URL in your browser. At the moment, it should look like this: https://www.facebook.com/dialog/oauth?client_id=XXXXXXXXXXXXX&redirect_uri=https%3A%2F%2Fzammad.example.com%2Fapi%2Fv1%2Fexternal_credentials%2Ffacebook%2Fcallback&scope=publish_pages%2C%20manage_pages&state=XXXXXXXXXX&ret=login&fbapp_pres=0&logger_id=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX&shared_id=TODO_SHARED_ID&cbt=XXXXXXXXXXX&ext=XXXXXXXXX&hash=XXX-XXXXXX-XXXXXXX
    Find the scope URL parameter and change it from &scope=publish_pages%2C%20manage_pages to &scope=pages_manage_metadata%2C%20pages_read_engagement%2C%20pages_read_user_content%2C%20pages_manage_posts%2C%20pages_manage_engagement
    So the final URL should look like this:
    https://www.facebook.com/dialog/oauth?client_id=XXXXXXXXXXXXX&redirect_uri=https%3A%2F%2Fzammad.example.com%2Fapi%2Fv1%2Fexternal_credentials%2Ffacebook%2Fcallback&scope=pages_manage_metadata%2C%20pages_read_engagement%2C%20pages_read_user_content%2C%20pages_manage_posts%2C%20pages_manage_engagement&state=XXXXXXXXXX&ret=login&fbapp_pres=0&logger_id=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX&shared_id=TODO_SHARED_ID&cbt=XXXXXXXXXXX&ext=XXXXXXXXX&hash=XXX-XXXXXX-XXXXXXX
  • Reload the page with the corrected URL and grant access

Hope I was able to help.

1 Like

It worked!! Thank you very much!