Help: [solved ]Opps.. I'm sorry, but you have insufficient rights to open this Ticket. note with all tickets

Infos:

  • Used Zammad version: 2.9
  • Used Zammad installation source: (source, package, …)
  • Operating system: Linux
  • Browser + version: Chrome latest, Safari latest

Expected behavior:

  • be able to open and change tickets

Actual behavior:

  • " Opps… I’m sorry, but you have insufficient rights to open this Ticket." note with all tickets, even the ones I am owner off

What did I do?

I am the admin of our Zammad instance which has just been installed and put into operation. Great job building Zammad btw!!!

Now I have added more e-mails and introduced a new nomenclature for roles, groups and overviews and renamed everything accordingly. (e.g. before: Bundesvorstand, now: BV.Vorstand)

Now I suddenly can’t open any more tickets. I have removed all the hooks in the agent settings and set them again. I should have full access to all tickets. But no change. The other agents can still use Zammad normally.

Is this bug known? What can I do to search for errors?

Many thanks in advance!

Hey @skepto,

which roles does your user have?
Go to Admin -> Users -> find your user and click on it

Which agent permissions are set in these roles?
Go to Admin -> Roles -> click on the assigned roles

Here’s a small explanation for those permission i’ve written in another topic:

cheers

1 Like

Hey @svnr-dvnkln,

my user has the role admin, agent and bv.vorstand

42

This are the agent permissions of BV.Vorstand

But no matter what agent permissions i give to my users. I cannot read any tickets.

Just to understand completely: If you have a role with right to all groups (or all roles together with the rights to all groups in overall) then you are not able to access the tickets?
Please take a look into your logfile and take a look if something appears there.

In the URL you’ll find an ID, do zammad run rails r 'p Ticket.find({ID})' and check in which group it lifes ( zammad run rails r ' p Group.find(GROUP-ID)'. Check if you have rights to that group.

Also, your template is incomplete.

1 Like

Yes, exactly that!

Do I find the logfile in the GUI, or on the server? I’m just Zammad-Admin, no Serveradmin. Have to go to our Systemadministrator if the latter is the case.

It’s on the server inside the root folder of your zammad installation.
There should be a folder* called log.

*a link to a folder depending on your os

1 Like

I was able to find the problem and fix it.
The checkbox “agent - access to CTI” was not set at the role “Admin”.

Thanks for your help!

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.