Generated links in signature are strange

  • Used Zammad version: 3.1.x
  • Used Zammad installation source: package
  • Operating system: CentOS 7
  • Browser + version: MF 68esr

Expected behavior:

A http link should refer to what is written in it.

Actual behavior:

The link looks like -> [ http://DRE-TS-01.company.com/#ticket/zoom/58] -> (#%7Bconfig.http_type%7D://#%7Bconfig.fqd)

The following link is generated in our signature:
grafik

This creates the following text:
grafik

So far so good… This has worked wonderfully until recently… But now this link links here:
grafik

Whats going wrong here? Hope for help.
Thank you, Daniel.

I tried to reproduce this, without any success.
I suspect that you copied the variable combination above from somewhere else within the Browser.

What makes me believe this is that it’s showing “blueish”, so as a link.
Please copy paste this via a notepad (run as is enough as well) to ensure you don’t copy any HTML content.

That should fix the issue :x

Hey, thanks for your answer…
I did nothing and today its working again…
Maybe the server had some confusions… I am happy now. :slight_smile:

1 Like

Good morning sirs,

here comes the rain again… :blush:

I think it is possible, that there is a conflict with Microsoft (or Outlook). I had problems with the sharp-sign (#) at the filesystem some months ago. Maybe its hard for Microsoft to resolve links with a sharp in it.
Is it possible to create a link without sharp? Only to test it…

Yours, Daniel.

Please provide the output of the following rails command (replace {signature} with the name of your signature):

zammad run rails r "p Signature.find_by(name:'{signature}').body

The URL issue should also exist on any other E-Mail-Client.
However, I can’t reproduce this.

Also, ensure that this is your signature you’ve been positevely testing for working, if it’s not, you might look at the wrong one.

1 Like

Hi,

you mean this one:

[root@dre-ts-01 ~]# zammad run rails r "p Signature.find_by(name:'default (CSR)').body"

"<div>\n<p>Solltest\ndu noch Fragen zum Verlauf haben, klicke auf den folgenden Link:</p>\n<p><a href=\"#%7Bconfig.http_type%7D://#%7Bconfig.fqdn%7D/#ticket/zoom/#%7Bticket.id%7D\"> \#{config.http_type}://\#{config.fqdn}/#ticket/zoom/\#{ticket.id}</a> <br></p>\n</div><div><br></div><div><br></div><div>Viele Grüße,<br>\n</div> \#{user.firstname} \#{user.lastname}<br><br>--<br> IT Support - *replaced*<br><span>*replaced*</span>\n<br> Email: helpdesk@*replaced*.com - Web: <a href=\"https://www.*replaced*.com\" rel=\"nofollow noreferrer noopener\" target=\"_blank\">https://www.*replaced*.com</a>\n<br>--"

I now copied the full signature into the Windows-Editor (without format) and copied it back…
The result is this one:

"<div>Solltest du noch Fragen zum Verlauf haben, klicke auf den folgenden Link:</div><div> \#{config.http_type}://\#{config.fqdn}/#ticket/zoom/\#{<a href=\"http://ticket.id\" title=\"http://ticket.id\" rel=\"nofollow noreferrer noopener\" target=\"_blank\">ticket.id</a>}</div><div><br></div><div>Viele Grüße,</div><div>\#{user.firstname} \#{user.lastname}</div><div><br></div><div>--</div><div>IT Support - *replaced*</div><div>*replaced*</div><div>Email: helpdesk*replaced*.com - Web: <a href=\"https://www.*replaced*.com\" title=\"https://www.*replaced*.com\" rel=\"nofollow noreferrer noopener\" target=\"_blank\">https://www.*replaced*.com</a>\n</div><div>--</div>"

well there’s your problem.
Looks like it has been copied and destroyed by that.

Well, anyway - copy the following into a notepad and then into Zammad (to ensure we don’t transport any HTML stuff). Also ensure to replace your stuff in the notepad.

Solltest du noch Fragen zum Verlauf haben, klicke auf folgenden Link:
#{config.http_type}://#{config.fqdn}/#ticket/zoom/#{ticket.id}


Viele Grüße
#{user.firstname} #{user.lastname}

-- 
IT Support - *replaced*
*replaced*

Email: helpdesk@*replaced*.com - Web:https://www.*replaced*.com

You can then check the signature again, if it gets broken again, I’d be quite thrilled to learn how you break it. :stuck_out_tongue:

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.