FQDN vs. URL for "Zeig mir dies in Zammad" / Mail-Content

In the Mail channel we work with the address (example) support@myprimarydomain.com .

Zammad is installed on the server (example) zammad.mysecondarydomain.com.

This is a problem for us:

Unfortunately, the mail server where Zammad delivers the SMTP mails only accepts mails from the sender support@myprimarydomain.com.
This is how we configured the e-mail channel.

Mails that are sent by Zammad, e.g. when follow-ups or reminders expire, also contain the link “Show in Zammad” at the end. This link is probably assembled with the variable config.fqdn.
So the link points to https://myprimarydomain.com/ticket… but not to the correct URL https://zammad.mysecondarydomain.com/ticket

How can we map the different domains so that we can continue to use the support@myprimarydomain.com address?

Issue 1 is not a Zammad issue I would think, this is a mail or domain trust issue. If domain 1 cannot receive something from Domain 2, you have obviously separated your domains for whatever reason but if they need to communicate with each other you should contact your network team or email team, maybe it’s not on an allow list or the likes, they should know.

Issue 2. Email and hostname are independent of each other, also the FQDN hostname of the server can be independent of the FQDN of Zammad but that can get messy unless you clearly document it, but for me it creates confusion so I avoid it

I read your message that Zammad is in Domain 2 but when the users receive a notification, the “Show in Zammad” link points to domain 1.

Is that correct?

Also confirm the FQDN in SYSTEM → BASE.

https://admin-docs.zammad.org/en/latest/settings/system/base.html

Thanks
Robert

Thank you for your answer!

“I read your message that Zammad is in Domain 2 but when the users receive a notification, the “Show in Zammad” link points to domain 1.”

Yes, that’s correct.

Additionally, when you have to divide your systems FQDN and notification sender address, this link might be of help for you:
https://admin-docs.zammad.org/en/latest/channels/email/settings.html

Thank you for the link, but I can’t find help for my problem there.

did you confirm your FQDN? in rails?

Setting.get(‘fqdn’)

The email will use your config.fqdn

" a href=“#{config.http_type}://#{config.fqdn}/#ticket/zoom/#{ticket.id}” target=“zammad_app”>#{t(‘View this in Zammad’)}</a"

Do this match SYSTEM → Base?

I have no clue if you have checked these or what config you have inputted, or even if you have customer notifications.

If you cannot get to the root of it try a custom template as a workaround until you figure it out.

Thanks
Robert

The mentioned workaround is not necessary at all.
OP simply doesn’t understand the difference that can be achieved with notification sender and the fqdn setting in combination.

1 Like