Don't autocomplete emails of disabled users

We often get emails sent to valid-email@fbi.gov with a cc to email-with-spelling-mistake@fbi.gov

email-with-spelling-mistake@fbi.gov gets added to our user list as a customer, I’m not sure if it’s as soon as we receive the email, but probably more likely when an agent clicks reply-all to it and doesn’t notice the spelling mistake so leaves it in.

So now when an agent in a different ticket wants to add in to the cc another person, email-with-spelling-mistake is shown as an auto-complete suggestion, often as the first suggestion as it was added after the correct email.

I’ve tried deleting the incorrect email addresses, but inevitably they get added back as it’s still in someones email as a cc and when they reply-all, in it goes again.

I’ve tried disabling the account, but it’s still shown as an auto-complete suggestion.

So I would like for a way to have it not be a suggestion in the auto-complete feature. Filtering out disabled accounts would work for me.

1 Like

@thorsteneckel bumping this up in case you didn’t get a notification :slight_smile:

Agree to that.
Disabled users schould not be suggested to auto-completion.
Or maybe there should be an configuration option if disabled users could be used by agents or not.

But I don´t see any usecase where it should be possible to use disabled users.

Did you read this one yet?


That’s what I was thinking of when I said I tried disabling the user, apparently it does nothing other than put a line through the users name.
Maybe I’ll keep a list of incorrect email addresses and delete them every day via a script, eventually they should stop appearing in an emails CC list and be gone for good.

This topic was automatically closed after 416 days. New replies are no longer allowed.