Disable password based authentication


  • Used Zammad version: 4.1
  • Used Zammad installation type: apt
  • Operating system: Ubuntu 18.04
  • Browser + version:

Expected behavior:

  • Disable password based authentication and only permit SSO with Office 365

Actual behavior:

  • Login page displays username and password forms

Steps to reproduce the behavior:

  • see login page


is it possible to disable the default password based authentication in zammad? If there is no such feature yet, would it be possible to disable the form-group and form-controls as a workaround in the file /opt/zammad/app/assets/javascripts/app/views/login.jst.eco ?

Thanks in advance.

1 Like

Resolved it myself. For anyone wondering, you can just delete the marked code after stopping zammad service, run sudo zammad run rake assets:precompile and start zammad again. It seems one would have to redo this after ervey zammad update since the file gets recreated. At least thats what I experienced.

1 Like

Is it possible to just comment out the lines? Do you have a screenshot of what the page looks like after doing this?

Please note that this “solution” is not update save and has to be applied upon every update.

I don’t see a enhancement in GitHub and I know the team doesn’t comment on feature requests, so @Joshua could you heart:

Seeing as it would be a useful feature request for you as well?

1 Like

Hi there,
Regarding to solution to hiding the default logon options.
Can you let me know what file is that you are altering? I’m looking around and can’t find it.

Thanks in advance.

Open the attached picture, in the bottom you see which file that was edited

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.