Can't process email <ActiveRecord::RecordNotFound>


  • Used Zammad version: 2.8.0
  • Used Zammad installation source: source
  • Operating system: Debian
  • Browser + version: Firefox (Win 10)

Expected behavior:

  • Tried to process an own test e-mail to Zammad which was desired to import correctly. e-mail import works just fine (e-mail is taken from IMAP), but can’t be processed further actually.

Actual behavior:

  • Ticket e-mail can’t be processed. Error message in scheduler-out.log says: “ERROR: Can’t process email” and “ERROR: #<ActiveRecord::RecordNotFound: Couldn’t find Ticket without an ID>”

  • This seems to be an identical problem to the closed but (publicly unresolved) ticket ! Can you tell me what the problem was that time?

Steps to reproduce the behavior:

By the way: I haven an active group named “AFP-Lookup” and an active filter for e-mail to be forwarded to this group:

Any e-mail to this address is forwarded to a collecting mailbox (“cdo00-zammad”) for all support requests before. Zammad pulls all e-mails from that mailbox via IMAP.

One thing I forgot before: Receiving e-mails worked on the vanilla Zammad setup. After (command-line) import from OTRS, e-mails can’t be processed any longer in the same system. This is also true for e-mails to the native e-mail address assigned to mailbox cdo00-zammad, so filter rules are not the problem.


This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.