Zammad slow in report and search index update

Infos:

Zammad report section https://hostname/#report and search don’t update in real time when new tickets are opened, you have to wait a few minutes for tickets to show.
Rebuilding the index seems to update it right away, but when a new tickets arrive the problem is back again.
When it happens I tried seeing if there were pending tasks using the rails command, but it responds with 0.
I also tried reinstallating elasticsearch and reinstalling the addon, but the problem didn’t resolve.
I tried reading the production log but i really don’t see any error, if you can think of something to search tell me and I’ll look.

  • Used Zammad version: 5.2.3
  • Used Zammad installation type: package
  • Operating system: CentOS 7
  • Browser + version: Chrome latest

Expected behavior:

Actual behavior:

  • Report section and search takes a few minutes to update when new tickets arrive, even if it’s only one ticket.

Steps to reproduce the behavior:

  • Open a new ticket
  • Search the ticket or open the report section right away
  • See the new ticket doesn’t show up
  • Wait some time for it to show up

exactly the same here.
New ticket, initially not found, neither via ticket number nor subject nor via search function text.
However, after some time still not found (about 20 minutes)
But if the subject is changed and saved again, the ticket can be found immediately.
bug?

Regards
Thomas

1 Like

If you have the problem too maybe it’s a bug, should we open an issue on github?

in the meantime there have been two updates. Since then I haven’t found anything abnormal here.
So I see no reason for us to open a ticket on github at the moment

I can confirm the problem was resolved with the latest updates.
Thank you for the information.