Zammad Reporting throwing errors

Infos:

  • Used Zammad version: 5.2.3
  • Used Zammad installation type: Source
  • Operating system: Ubuntu 22.04
  • Browser + version: Chrome 106.0.5249.119

Expected behavior:

Show Ticket reports

Actual behavior:

Gives error: “StatusCode 500”, with message below, after upgrade to new version

Unable to process GET request to elasticsearch URL 'http://localhost:9200/zammad_production_ticket/_search'. Check the response and payload for detailed information:

Response:
#<UserAgent::Result:0x000055d20cebaaa8 @success=false, @body="{\"error\":{\"root_cause\":[{\"type\":\"x_content_parse_exception\",\"reason\":\"[1:241] [date_histogram] unknown field [calendar_interval], parser not found\"}],\"type\":\"x_content_parse_exception\",\"reason\":\"[1:241] [date_histogram] unknown field [calendar_interval], parser not found\"},\"status\":400}", @data=nil, @code="400", @content_type=nil, @error="Client Error: #<Net::HTTPBadRequest 400 Bad Request readbody=true>!", @header={"content-type"=>"application/json; charset=UTF-8", "content-length"=>"161"}>

Payload:
{"query":{"bool":{"must":[{"range":{"created_at":{"from":"2022-01-01T00:00:00Z","to":"2022-12-31T23:59:59Z"}}}],"must_not":[{"term":{"state.name.keyword":"merged"}}]}},"size":0,"aggs":{"time_buckets":{"date_histogram":{"field":"created_at","calendar_interval":"month","time_zone":"Europe/London"}}},"sort":[{"updated_at":{"order":"desc"}},"_score"]}

Payload size: 0M

Screenshot 2022-10-26 at 11.55.54

Steps to reproduce the behavior:

Click Reporting icon on bottom ribbon.

Are you using the -all- report or did you specify your own reporting profile?
What elasticsearch version is this?

Possibly the issue can be solved by reindexing in case the index contains “broken” data.

Hi,

I’m using the reports that came with out of the box, nothing specific. My elasticsearch version is 6.8.23.

I’ve tried reinstalling elasticsearch and re-indexing but didn’t fix it.

Well there you go.
Please make sure to follow the required update steps ( Updating Zammad — Zammad documentation ) which would lead you to the software dependencies:
Software — Zammad documentation

Elasticsearch 7.8+ is mandatory since Zammad 5.0.
That was also mentioned in our release notes.

Thanks MrGeneration.

Upgrading Elasticsearch sorted the issue.

2 Likes