Zammad PostgreSQL Account


I intentionally change the PostgreSQL zammad account password and not change to database.yml at the config folder. but why still no error encounter and still access the zammad web site/user/tickets and i think everything is normal

  • Used Zammad version: 2.8.0
  • Used Zammad installation source: Via Deb
  • Operating system: Ubuntu 18.04
  • Browser + version: latest

Expected behavior:

Got an error and unavailable to access the website or users or existing tickets

Actual behavior:

  • no error encountered

Steps to reproduce the behavior:

  • changed the zammad account password at postgreSql ang not change in database.yml at opt/zamamd/config

Did you restart the Zammad service or check the log file?
I’m sure you have to get errors at some point.

Yes, already restart zammad even the ngnix and the machine :smile: still not encounter any error i can request new ticket and closed, triggers are working. that’s why I’m confused, or I’m missing some configurations ?
Searched all ticket, etc.are working, in Administrator UI no error in monitoring.

What kind of error are possible in my production log?

Please provide your log file.
Normally you should find connection errors for PGSQL inside of them. They should be logged with “ERROR”

Sir already sent via PM the production log,

Please ignore if you see error like - [Failing background jobs.;Failed to run background job #1 ‘BackgroundJobSearchIndex’ 10 time(s)
I having a problem after install zammad but already fixed when i update the system… after that I already replaced the zammad account password in postgresql and edit also the database.yml and intentionally not matched to see if i encounter any error but still no error encountered


i can’t find any database related errors.
Zammad uses the password defined in database.yml - if the password is incorrect, zammad will throw erorrs and not function at all. If after restarting Zammad, the old login still works, I suppose that the database password hasn’t been changed correctly.

I can’t help you with that, sorry.

Thats why i confused, I installed new zammad via deb … ang after the setup, Im not touch the PostgreSQL settings only I changed is the database.yml in config folder… I changed the password but still no error encounter after I restart zammad and the machine…

Sorry but this has to be because the password hasn’t been changed correctly (within postgresql).
This is out of scope from us, sorry.

Im not touching the postgreSQL settings in my second testing, I only changed is the database.yml in zammad config folder… and after restart I expecting to receive an error but still working normal,

To continue my configuration I will now skipped that testing for zammad dabatase.yml,

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.