Zammad on Microsoft Edge: images with transparency

I am using Zammad on Microsoft Edge. When I paste images with transparency, such as an edge shadow, from the clipboard into Zammad, the shadow is displayed as a black area.

The images have the correct transparency information. When I paste them into other programs such as Word, Excel, Teams, or Firefox, the transparency information (in this case, the edge shadow) is displayed correctly. However, only Edge loses the transparency and displays it as black. This was not an issue until about six months ago - previously, Edge was able to display the images correctly.

Does anyone know of a solution to this problem?

Thank you!


  • Used Zammad version: Zammad Version 5.3.1-1671805004.9b7729da.bionic
  • Used Zammad installation type: package
  • Operating system: Windows 11 Pro 22H2
  • Browser + version: Edge Version 112.0.1722.48 (Offizielles Build) (64-Bit)

Expected behavior:

Shadow or transparency should be maintained

Actual behavior:

Shadows or transparency are displayed as a black area.

Steps to reproduce the behavior:

Paste image with a transparency (e.g. edge shadow) via the clipboard.

Each browser handles inline images and their support and pasting differently.
You could double tab if Zammad is a possible culprit if you paste the same image on another page in Edge. The result should be the same if it’s the Browser and not Zammad.

Also a good shot might be to update to Zammad 5.4.1 which is the current latest including security updates. As Zammad uses a rolling stable, issues you have on an older version might be gone on new ones already.

Thank you :wink: I have already installed Zammad 5. In the meantime, I assume that the problem probably lies with Edge.

For your Information:

So far no solution has been offered by either side.

What screen capture software do you use? We use Snagit.

We use “screenpresso”.

Ha… I knew I did see that question before but wasn’t able to find it.
My answer from then basically hasn’t changed.

I solved the problem somewhat unconventionally: In SnagIt’s program settings there is a setting “Disable image transparency for clipboard”. I checked the box and since then it works - even with transparent shadow! Why? Doesn’t matter, the main thing is that it works.

1 Like