Zammad mail setup

Infos:

  • Used Zammad version: 3.2.x
  • Used Zammad installation source: RPM
  • Operating system: CentOS7
  • Browser + version: Brave 1.9.76 / Chromium 81.0.4044.138

Expected behavior:

  • Auto setup email

Actual behavior:

  • Getting error when trying to add email account

Steps to reproduce the behavior:

  • We are using O365, and are using kiosk license which limits us to POP3. When creating new email account the auto setup can’t complete and pops window with expert settings.
    When I enter mail setting manually I’m getting several errors regarding the settings I’m using:
    Setup 1:
    Type: POP3
    Host: outlook.office365.com
    User: entered
    Pass: entered
    SSL/STARTTLS: yes
    Port: 995
    Error: Connection reset by peer - SSL_connect

Setup 2:
Type: POP3
Host: outlook.office365.com
User: entered
Pass: entered
SSL/STARTTLS: no
Port: 110
Error: -ERR Command is not valid in this state.

I have tried also with a gmail account but with the same results.

When trying to setup outgoing mail settings:

Host: smtp.office365.com
User: entered
Pass: entered
Port: 587
Error: 554 5.2.0 STOREDRV.Submission.Exception:SendAsDeniedException.MapiExceptionSendAsDenied; Failed to process message due to a permanent exception with message Cannot submit message. 0.35250:751E0000, 1.36674:0A000000, 1.61250:00000000, 1.45378:02000000, 1.44866:E0220000, 1.36674:0E000000, 1.61250:00000000, 1.45378:E5220000, 1.44866:3A010000, 16.55847:36110000, 17.43559:0000000024020000000000000000000000000000, 20.52176:140FE58B1600F01F00000000, 20.50032:140FE58B7E17F01F00000000, 0.35180:140FE58B, 255.23226:EB1E0000, 255.27962:0A000000, 255.27962:0E000000, 255.31418:1C1F0000, 0.35250:0A00D480, 1.36674:0A000000, 1.61250:00000000, 1.45378:02000000, 1.44866:38000000, 1.36674:32000000, 1.61250:00000000, 1.45378:3D000000, 1.44866:01000000, 16.55847:A4000000, 17.43559:0000000070030000000000000100000000000000, 20.52176:140FE58B1600101053000000, 20.50032:140FE58B7E170000780A0000, 0.35180:58000000, 255.23226:4800D13D, 255.27962:0A000000, 255.27962:32000000, 255.17082:DC040000, 0.27745:860A0000, 4.21921:DC040000, 255.27962:FA000000, 255.1494:8B0A0000, 0.38698:05000780, 0.37692:01000000, 0.37948:0F010480, 5.33852:00000000534D545000000100, 7.36354:010000000000010901040480, 4.56248:DC040000, 7.40748:010000000000010B24000100, 7.57132:000000000000000024000100, 1.63016:32000000, 4.39640:DC040000, 8.45434:3F989AA02D35C243A6D8D6CF1DC1375124000100, 5.10786:0000000031352E32302E333034352E3031343A414D36505230354D42343138313A66383933333539622D303765302D343135332D623731302D30336265393735663232326600201000000000, 7.51330:3CBF2A04C006D80800000000, 0.39570:4F000000, 1.55954:0A000000, 0.49266:56000000, 1.33010:0A000000, 2.54258:00000000, 0.40002:09000000, 1.56562:00000000, 1.64146:32000000, 1.33010:32000000, 2.54258:DC040000, 255.1750:AF000000, 255.31418:0A005D36, 0.22753:DF080000, 255.21817:DC040000, 0.64418:0A00F565, 4.39842:DC040000, 0.41586:B9000000, 4.60547:DC040000, 0.21966:80030400, 4.30158:DC040000 [Hostname=AM6PR05MB4181.eurprd05.prod.outlook.com]

Is there something I’m doing wrong?
If I can give more info please tell me what You need.

Thank You!

This sounds like you’re having two issues and mixing two different configurations steps: email channels (accounts) and the notification channel.

Why I think that?

Let’s me believe that you’re configuring a notification channel. Technically this channel has nothing to do with email sendout to customers. Ensure you set your notification sender to a valid mail address if noreply@fqdn is not correct (see: https://admin-docs.zammad.org/en/latest/channels/email/settings.html)

As for your other problem

Can have several reasons. Ensure that your server can communicate outbound to port 995. If it can, please have a look into your logfile if maybe more information on this issue is provided.


Also, you should consider to update ASAP. Zammad 3.2 is prune to serious security issues which are solved with Zammad 3.3 .

Thank You for Your reply!

I updated my Zammad version as You suggested, I’m now running 3.3.x

You are right regarding my mix-up of the two, notification channel is now working.

In production.log when creating new account I get the following:

    INFO -- : Started POST "/api/v1/channels_email_inbound" for 192.168.0.69 at 2020-06-04 17:47:14 +0200
    INFO -- : Processing by ChannelsEmailController#inbound as JSON
    INFO -- :   Parameters: {"adapter"=>"pop3", "options"=>{"host"=>"outlook.office365.com", "user"=>"[MAIL_ADDRESS]", "password"=>"[FILTERED]", "ssl"=>true, "port"=>"995"}}
    INFO -- : Enqueued UserDeviceLogJob (Job ID: 5bef59e0-5bcb-4ff9-ac33-47e2df837b5d) to DelayedJob(default) with arguments: "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.138 Safari/537.36", "192.168.0.69", 3, "-1235051944", "session"
    INFO -- : fetching pop3 (outlook.office365.com/[MAIL_ADDRESS] port=995,ssl=true)
    INFO -- : Completed 200 OK in 44ms (Views: 0.2ms | ActiveRecord: 14.5ms)
    INFO -- : 2020-06-04T17:47:14+0200: [Worker(host:localhost.localdomain pid:2980)] Job UserDeviceLogJob [5bef59e0-5bcb-4ff9-ac33-47e2df837b5d] from DelayedJob(default) with arguments: ["Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.138 Safari/537.36", "192.168.0.69", 3, "-1235051944", "session"] (id=20283) (queue=default) RUNNING
    INFO -- : Performing UserDeviceLogJob (Job ID: 5bef59e0-5bcb-4ff9-ac33-47e2df837b5d) from DelayedJob(default) with arguments: "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.138 Safari/537.36", "192.168.0.69", 3, "-1235051944", "session"
    INFO -- : Performed UserDeviceLogJob (Job ID: 5bef59e0-5bcb-4ff9-ac33-47e2df837b5d) from DelayedJob(default) in 5.55ms
    INFO -- : 2020-06-04T17:47:14+0200: [Worker(host:localhost.localdomain pid:2980)] Job UserDeviceLogJob [5bef59e0-5bcb-4ff9-ac33-47e2df837b5d] from DelayedJob(default) with arguments: ["Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.138 Safari/537.36", "192.168.0.69", 3, "-1235051944", "session"] (id=20283) (queue=default) COMPLETED after 0.0214
    INFO -- : Started GET "/api/v1/channels_email?_=1591280597643" for 192.168.0.69 at 2020-06-04 17:47:15 +0200
    INFO -- : Processing by ChannelsEmailController#index as JSON
    INFO -- :   Parameters: {"_"=>"1591280597643"}
    INFO -- : Completed 200 OK in 6ms (Views: 0.3ms | ActiveRecord: 1.3ms)

Unfortunately, I’m not seeing anything obvious…

That’s odd. The logfile does not reflect the error message nor “ERROR” tagged messages?

Yes, everything look OK, but I’m getting Connection reset by peer - SSL_connect

Untitled

I’m all out of ideas, any help would be greatly appreciated.

I’m afraid I can’t help further as I can’t reproduce this issue.
As you’re a hosted exchange 365 user and I tested against the exact same systems, this in theory should work.

Please ensure that the affected account is allowed to fetch mail by pop.
Also, ensure that your server can communicate via Port 995 with any other external system.

I suspect your firewall to be in your way currently, because you’re having the same issue with gmail, not just gmail.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.