Zammad from the sources under aaPanel

Hello Zammad team

I would like to install Zammad from the sources to run it together with aaPanel. aaPanel should then be responsible for the web server and certificates.

Unfortunately I have a problem with the installation.

Apparently the documentary is no longer the youngest.

Ruby 2.5.5 (see: https://docs.zammad.org/en/latest/prerequisites/software.html#ruby-programming-language) should be used. Unfortunately, this is not available in Debian. How is this installed with the Debian package or which package.

Are the dependencies out of date: https://docs.zammad.org/en/latest/prerequisites/software.html#package-dependencies

Maybe someone here can help me get Zammad up and running.

Also here (see: https://docs.zammad.org/en/latest/install/source.html#install-all-dependencies) I get tw errors that data cannot be written. Although I also assigned the extracted data to the user zammad: zammad.

ok if I want to install the standard Ruby from Debian 9 he would install me the 2.3.
How do you go about getting 2.5.5?

apt-get install ruby

Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages were automatically installed and are no longer required:
libgmp-dev libgmpxx4ldbl libtcl8.6 libtk8.6 libxss1 ruby2.3-doc
Use ‘apt autoremove’ to remove them.
The following additional packages will be installed:
libruby2.3 rake ruby2.3
Suggested packages:
ri ruby-dev
The following NEW packages will be installed:
libruby2.3 rake ruby ruby2.3
0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/3,358 kB of archives.
After this operation, 14.4 MB of additional disk space will be used.
Do you want to continue? [Y/n] n
Abort.

Have ruby (2.3.x) as well as rake, bundler and rails
installed via apt.

Now when I run as user Zammad “gem install bundler rake rails” this one comes here!

zammad@vmd42762:~$ gem install bundler rake rails

Fetching: bundler-2.1.4.gem (100%)
ERROR: While executing gem … (Gem::FilePermissionError)
You don’t have write permissions for the /var/lib/gems/2.3.0 directory.
zammad@vmd42762

Ok I have now switched to CentOS 8 and installed aaPanel and ES.

I’m running Ruby 2.5.5 and if I now “gem install bundler rake rails”

then this message comes

[zammad@vmd42762 ~]$ gem install bundler rake rails
Fetching: bundler-2.1.4.gem (100%)
Successfully installed bundler-2.1.4
Parsing documentation for bundler-2.1.4
Installing ri documentation for bundler-2.1.4
Done installing documentation for bundler after 7 seconds
Fetching: rake-13.0.1.gem (100%)
Successfully installed rake-13.0.1
Parsing documentation for rake-13.0.1
Installing ri documentation for rake-13.0.1
Done installing documentation for rake after 0 seconds
Fetching: concurrent-ruby-1.1.6.gem (100%)
Successfully installed concurrent-ruby-1.1.6
Fetching: i18n-1.8.2.gem (100%)

HEADS UP! i18n 1.1 changed fallbacks to exclude default locale.
But that may break your application.

If you are upgrading your Rails application from an older version of Rails:

Please check your Rails app for 'config.i18n.fallbacks = true'.
If you're using I18n (>= 1.1.0) and Rails (< 5.2.2), this should be
'config.i18n.fallbacks = [I18n.default_locale]'.
If not, fallbacks will be broken in your app by I18n 1.1.x.

If you are starting a NEW Rails application, you can ignore this notice.

For more info see:
https://github.com/svenfuchs/i18n/releases/tag/v1.1.0

Successfully installed i18n-1.8.2
Fetching: thread_safe-0.3.6.gem (100%)
Successfully installed thread_safe-0.3.6
Fetching: tzinfo-1.2.6.gem (100%)
Successfully installed tzinfo-1.2.6
Fetching: minitest-5.14.0.gem (100%)
Successfully installed minitest-5.14.0
Fetching: zeitwerk-2.2.2.gem (100%)
Successfully installed zeitwerk-2.2.2
Fetching: activesupport-6.0.2.1.gem (100%)
Successfully installed activesupport-6.0.2.1
Fetching: rack-2.2.2.gem (100%)
Successfully installed rack-2.2.2
Fetching: rack-test-1.1.0.gem (100%)
Successfully installed rack-test-1.1.0
Fetching: mini_portile2-2.4.0.gem (100%)
Successfully installed mini_portile2-2.4.0
Fetching: nokogiri-1.10.8.gem (100%)
Building native extensions. This could take a while...
ERROR:  Error installing rails:
        ERROR: Failed to build gem native extension.

    current directory: /opt/zammad/.gem/ruby/gems/nokogiri-1.10.8/ext/nokogiri
/usr/bin/ruby -r ./siteconf20200213-16591-1azjok3.rb extconf.rb
mkmf.rb can't find header files for ruby at /usr/share/include/ruby.h

extconf failed, exit code 1

Gem files will remain installed in /opt/zammad/.gem/ruby/gems/nokogiri-1.10.8 for inspection.
Results logged to /opt/zammad/.gem/ruby/extensions/x86_64-linux/2.5.0/nokogiri-1.10.8/gem_make.out
2 gems installed
[zammad@vmd42762 ~]$

Even if I want to run it under aaPanel. It is a basic installation from the sources.

Finally, aaPanel only provides Apache or NGNIX.

Has nobody had this mistake yet?