Zammad E-Mail Setup shows 'LOGIN FAILED'

Cheers,

i was setting up Zammad a while ago and in the beginning i had struggles with the email setup. After some tries i figured it out. Since then Zammad was working like a charm. From one to the next day the email setup didn’t work anymore. In the logfiles (production.log) i’m having the following error:

I, [2021-01-20T06:25:21.695716 #23908-47310801026320] INFO – : fetching imap (mail.our-domain.de/helpdesk.otrs port=993,ssl=true,starttls=false,folder=INBOX,keep_on_server=false,auth_$

E, [2021-01-20T06:25:21.833494 #23908-47310801026320] ERROR – : Can’t use Channel::Driver::Imap: #<Net::IMAP::NoResponseError: LOGIN failed.>

E, [2021-01-20T06:25:21.833609 #23908-47310801026320] ERROR – : LOGIN failed. (Net::IMAP::NoResponseError)

In the email settings the error appears like this:

The weird thing is that the email outbound works without any problem. I doublechecked the login credentials, the account and everything mandatory regarding the AD User.

  • Used Zammad version: 3.6.X
  • Used Zammad installation source: (Official Repo)
  • Operating system: Ubuntu 18.04.4 LTS
  • Browser + version: Firefox 84.0.2 (64-Bit)

Expected behavior:

  • Setting up email inbound service as before

Actual behavior:

  • I can’t set up email inbound accound for fetching mails.

Steps to reproduce the behavior:

  • Deleted the email settings and tried to re-enter. The issue remains the same.

Hi @clu91

outgoing email uses SMTP, which is a totally different protocol to IMAP, the one you use for incoming emails.

WIth that said, please try disabling the “SSL/STARTTLS” from the drop-down menu. Additionally, please make sure that your IMAP server listens on port 993. If not, try the standard one: 143.

HTH,
Martin

Hi @rsysadmin,

i already tried every possible configuration. With setting ‘No’, with Port 143, with POP3 even. Also not working. I cant understand why it was working for more than 9 months and now i an issue.

Regards

hi @clu91

can you try with an IMAP client, like Thunderbird? Maybe there is a typo in the password… a common mistake.

HTH,
Martin

It might also be helpfull to check the logs from the mailserver, while you attempt to connect.

some other pointers;
from the documentation (class Net::IMAP - Documentation for Ruby 2.6.0);


thus also check the mailbox exists/spelled correctly.

if you’re using gmail, maybe checkout; ruby on rails - Net::IMAP::NoResponseError: Invalid credentials (Failure) - Stack Overflow see 3rd comment => Less secure apps & your Google Account - Google Account Help

We dont use Gmail for mailtransfer. We having our own Exchangeserver. If i connect via Telnet from the Ubuntu, Zammad is running on to the exchange on Port 993 it works.

The problem fixed itself. It is just working again. That’s highly weird.

This was due to the following bug that was backported to stable about 3,5 weeks ago: