Zammad defaults to Czech language

I have carried out a clean install of Zammad on CentOS 7. The language defaults to Czech, I can translate with Chrome and set my lang preference under #settings/branding to English but it does not change.

I am led to believe this could be a locale setting in Rails but I’m not sure how to resolve this.

If I run the zammad run rails r 'p Locale.count' command it returns 38.

If I run system locale command it returns LANG=en_GB.UTF-8

Does anyone have any advice?

update: I have run the I18n.locale command which returns “en” but still the language is in Czech.


Please take a look into your language settings within your profile. Every agent can use his own language. If your login screen is in english without being logged in, everything is fine.

Hi @MrGeneration

The language settings in my profile are set to English. The entire system, incl. login page is in Czech.

What version of elasticsearch, zammad and database are you using?

How have you installed zammad?

I followed and the versions are

Zammad - 2.6.x.
Elasticsearch - v5.6.11
PostgreSQL - 9.2.24

It seems like your browser prefers to use “Czech” for displaying pages.
As I had testing something else I discovered that it’s not enough to simply tell Zammad it’s having another branding. This is caused by your browser. Sorry for taking so long for finding that out.

German visitors of your page will see the login in German and english ones in english.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.