Zammad.conf issue


I’ve tried building his numerous times now on different OS (ubuntu, centos etc), following the instructions. When I perform the copy instruction to copy the conf file, it states that the “upstream” directive is not allowed. I then comment this out and I get the same error saying “server” directive not allowed. It does this whether I edit the file or not, as soon as I copy the default file and reboot nginx, failure. Can’t get past this point as I don’t know what the default conf should be.

Can someone please help me or give me a copy of their working conf file?

  • Used Zammad version: 4.1
  • Used Zammad installation type: package
  • Operating system: Debian 10 currently, tried CentOS and Debian 9 too
  • Browser + version: Brave / Firefox

Expected behavior:

Nginx restarting properly and allowing web interface to be accessible.

Actual behavior:

*Nginx fails to restart after copying the conf file.

Steps to reproduce the behavior:

*copy the conf file using “cp /opt/zammad/contrib/nginx/zammad_ssl.conf /etc/nginx/sites-enabled/zammad.conf” command, then restart nginx.

Image of error

Managed to figure it out, please close this thread.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.