Visual differences between Knowledge Base for Agents and Public

  • Used Zammad version: 3.4.x
  • Used Zammad installation source: source
  • Operating system: CentOS Linux 7
  • Browser + version: Chrome / latest

Expected behavior:

Hello,
we haven’t started to make our zammad-installation availabe to our customers (=company workers) yet. But we are working on implementing a knowledge base and want to have internal aswell as public articles. I’ve started to do this by changing the visibility of articles to “public” or “internal”.

I want to have nice looking articles for the customers aswell as for the agents.

My expectation for text-wrapping in the internal KB would be that words are wrapped just like in the public KB like this:

Actual behavior:

When using the knowledge base from agents perspective (/#knowledge_base/1/locale/de-de), the textwrapping looks off in the internal view for the agents (same article):

Steps to reproduce the behavior:

  • Create an KB article with a few paragraphs

Is there any way to make the “internal” view of the KB for the agents better, so that they can read internal knowledge base articles, e.g. how to deal with certain problems or how to use the ticket system, without the irritating wrapping of certain words which makes it hard to read?

OR is there any way so that internal articles can be seen for agents when they use the “public” KB ( /help/de-de) but not for customers?

Thank you very much in advance!

This is possible by default, have you tried it? As an Agent you can of course use the public view of the knowledgebase and you will see hidden articles. Agents have an additional bar at the top indicating wether an article is public or hidden.

The wordwrap example you showed in the screenshots is a bug in my opinion. Words should not be broken up to be wrapped at all.

I tried to see internal articles in the public KB, but I can’t. Theres no additional bar at the top to see if it’s hidden or not and the articles are not viewable.
I specifically made one of my test-accounts an agent and tested it, but it’s not possible. Any chance i have to activate it somewhere?

OK I played around with my test installation and I found out that your agents need the Editor rights to the knowledgebase for this to work. I assumed that Reader would also work but with Reader rights only the internal articles are hidden.

I just tested it, the agents have editor rights. I also tried with read only and with both rights but i still can’t see internal articles in the public base, even if I delete my cache and so on.
image

Is there any other setting I have to make or is there anything blocking the view?

No that’s all I have to do. If I set the editor only, or editor and reader both, then refresh the page in a different browser where the agent is logged in then I immediately see internal articles and categories.

2020-07-16 14_06_44-common solutions Knowledge Base

If I click on an article I see an additional bar at the top of the page like this:

2020-07-16 14_06_24-common solutions Knowledge Base - Kundenliste

If I take away the editor right and give only reader and go back to the browser with the logged on agent and press F5 the internal stuff disappers.

If that doesn’t work for you I don’t know why. Try restarting Zammad maybe?

I’ve restarted Zammad now after changing the rights according to your Screenshots and did everything the same way as you but it’s still the same issue. I also don’t see any bars on top of the page.
Don’t know what else to do - would be really great if my agents could see the internal stuff in the nicely looking public KB too.

Ensure that, if you use translated content, the article you’re looking for is available in that language. If it’s not, change the language on the page. The KB does use the agents language preference if being logged in.

I can’t reproduce your problem, so biggest chance is above.


It indeed is and will be addressed on Zammad 3.5 release:

1 Like

I didn’t translate anything and I have activated German as the only language - I don’t think that’s the problem then.

Is there anything else I could do to check what the problem could be?

Sorry but my crystal ball currently is on RMA.

Provide the configuration of the user in question.
Also the role configurations the user is assigned to.

Also provide the visibility settings of the affected article.

Hey,
the following Screenshots show the configurations you asked for. I didn’t want to disturb you - no need to be mean (regarding the crystal ball thing) - it’s not a really big problem for me but in the end I ask myself why this is happening and can’t seem to find the reason why.



image

Sorry if you find that being mean. It wasn’t supposed to be an asshole move.
Kristallkugel in der Wartung usually is a term used by many technicans, at least in my region.

Again, sorry!


I can see that agents do have editor right for the knowledge base, but not reader.
Could you please add reader to the agent role as well? (You can combine them without issues)

My guess currently is that the /help frontend does care about that.
Don’t know why yet, but this would explain your issues!

1 Like

Alright, then it was just a misunderstanding.

I just did that but i still got the same issue.

I think it’s relevant: I don’t see this thing that awedor described - not even as an admin. There was a time (when the knowledge base was pretty newly setup for me) where I saw this and where I also could see internal articles.
We upgraded to 3.4 in the meantime - but I don’t know exactly if it disappeared after that or already before.

Are there any config files i could dig in to further investigate or is there a possibility that it has something to do with the 3.4 upgrade?

I just found the error! It’s so simple but yet so stupid that I didn’t see it.

I use the Zammad system by going on the Webinterface via the servers IP - http://INTERNAL_IP/#dashboard

But when I click on this button image it always redirects me to the DNS-Version of the interface (srvzammad/help/). In the DNS version I can see everything as expected.

Is there any way we can change the redirection link or is it done by system settings of zammad directly? Would be great if the mentioned button just used /help/de-de instead of DNS_NAME/help/de-de.

Just for me to get this right…
You do not see the mentioned bar / visual information if you access the knowledgebase via an URl that does not match the FQDN Zammad expects you to use? If you use the FQDN of the system, everything works as expected…?

Zammad technically doesn’t redirect at any point here. Instead it provided you the complete URL to overcome possible issues you may encounter. For this it uses it’s FQDN that’s configured.

The FQDN is configured within System settings

Yes, exactly this is the problem. We have the FQDN set as “srvzammad01”. I can only use the Knowledgebase as intended when I use the FQDN - not when I use the Knowledgebase with the servers IP.

I’m sorry, but I can absolutely not reproduce this behaviour.
Zammad does not redirect me at all. As there’s redirections involved, I suppose that this is a webserver configuration on your end doing it.

So I also suspect that there’s either information being lost or maybe information cannot be loaded.
I’m afraid that this is how far I can help. My system is a vanilla Zammad 3.4 upgraded from 2.8 over the time.

Alright, thank you very much for your help.

We know what the problem is and we know how to go around it - therefore it’s not a big deal for us anymore. Could’ve been a general Zammad Problem, but in the end I think we can live with it.

Thank you very much all!