Variable "#{config.fqdn}"


  • Used Zammad version: 5.0.x
  • Used Zammad installation type:package
  • Operating system: Ubuntu 20.04
  • Browser + version: Chrome

Expected behavior:

When I changed the fqdn, I would expect the variable “#{config.fqdn}”

Actual behavior:

But the real problem is that on any space when we use the variable “#{config.fqdn}” It only work with the ip public, and we need that it use the domain configured.
for example: http://104.154.888.999/#ticket/zoom/##, But I expect that it works with: http://ourdomain/#ticket/zoom/##. Only need what steps I need for changed the value of the variable “#{config.fqdn}”, I tried to change manually on the triggers, the variable with ourdomain, but it work bad. I changed the localhost for my ourdomain

Steps to reproduce the behavior:

When we use any trigger or email with the variable “#{config.fqdn}”, It doesn’t work how we would like

Zammad works best with exactly one FQDN.
If that doesn’t work for you for whatever reason, use the most used FQDN.

The FQDN of your vHost file (webserver) and the FQDN configured in Zammad technically are independent and are not linked. Changing it on the web server end also required you to change it within Zammad.

The FQDN can be found in the system settings:

This is also where the value from config.fqdn comes from.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.