Using ruby ​​3.3 with zammad 6.3 ?


  • Used Zammad version: 6.3
  • Used Zammad installation type: package
  • Operating system: Rocky Linux 8
  • Browser + version: Firefox 115.6.0esr

Expected behavior:

Actual behavior:

The Rocky Linux 8 and 9 repositories only offer ruby ​​in version 3.1 or 3.3.
Zammad 6.3.1+ is currently validated for a version 3.2.4 of ruby.

Are there plans to validate it for ruby version 3.3? If yes, how soon?
Isn’t it already functional with version 3.3?

Steps to reproduce the behavior:

You are using a package installation. Follow the installation / update procedure for that installation type. Package installations come with bundled ruby versions and thus do not need another installed ruby version.

Thank you for the info.
And when installing from source? Can ZAMMAD work with ruby ​​3.3?

What do you think?
Each Zammad version has a fixed and required ruby version. Just stick to it and don’t experiment.

I’m wondering if there are any plans to upgrade to ruby ​​3.3? If so, is this planned before the end of life of version 3.2?

We do not communicate any ETAs or roadmaps.
We regularly upddate our dependencies latest with releases.

Just check release notes and the documentation and you’ll see when it’s time.