URGENT - Zammad Email Loop


I cant delete my SMTP Email Channel and zammad keeps sending mails even if it is turned off.
I dont know that the cause is but how can i delete the Email Channel - there is no delete button as you can see in the Screenshoots.


And the error is coming from cause i reset the password of the mail account but i keeps sending mails.
Please help it is really a pain since i’m getting 1000s of Emails…


Change it to Local MTA in dropdown “SEND MAILS VIA”.

Best regards

Hi, had that idea too but i get the following error.
2023-05-09 10_31_22-Support System - E-Mail


Is your system still sending emails after the change?

Best regards

Hi, I can’t change to MTA get the error.

Read and understand the error message: You need sendmail installed.
That means Zammad requires a local MTA in that operation mode.

Also note that you have no email channels configured, thus no new emails would go in (and out). If your notification channel “goes berserk” it’s definitely everything but an email loop. Adjust the notification settings of your agents if Zammad sends to much mail.

If you have productive email accounts configured, make sure you look in the right section (e.g. if you actually use Microsoft 365 as example). Right now it’s hard to tell what’s going on because you barely shared enough information to provide a better fix approach of whatever goes wrong.


So what happened when i connected my M365 account with zammad:
all emails from my mailbox got in there as tickets and also really old mails from last year.
As soon as i saw the Email Loop coming in, i deleted that M365 connection and also the App Registration but the loop continues to run.

I also checked my exchange server and the external smtp account.
I think that the mails got in my exchange rules and they are beeing processed now (delayed of course)

I have installed sendmail now so lets see if that helps.

Notification mails are sent delayed and thus the removal of an account may take time to get recognized by Zammads background worker. And already imported tickets are naturally worked on delayed (in terms of the notification).

That’s more of a “wait until Zammad finished” thing. Switching the notification channel to something non functional is not a solution in this scenario. Also this is not a loop.

I’d like to recommend to have a read of the documentation before you add channels to Zammad:

Especially the channel section is relevant and might to help improving your experience on that regard: