Update Zammad package from 5.0.3-1646129126 to 5.1.1-1652083642

Infos:

  • Used Zammad version: 5.1.1-1652083642.e5527951.bionic
  • Used Zammad installation type: package
  • Operating system: Ubuntu 18.04.6
  • Browser + version: Edge Version 101.0.1210.32 64bit

Expected behavior:

  • Zammad package update succes

Actual behavior:

Setting up zammad (5.1.1-1652083642.e5527951.bionic) ...
# (Re)creating init scripts
Nothing to do.
Nothing to do.
Nothing to do.
# Enabling Zammad on boot
# Stopping Zammad
# Clear cache...
nil versions are discouraged and will be deprecated in Rubygems 4
# database.yml found. Updating db...
nil versions are discouraged and will be deprecated in Rubygems 4
== 20210827095053 AddTicketArticleTypeFacebookDirectMessage: migrating ========
== 20210827095053 AddTicketArticleTypeFacebookDirectMessage: migrated (0.0423s)

== 20210903072144 MapTranslationTimeFields: migrating =========================
== 20210903072144 MapTranslationTimeFields: migrated (0.0776s) ================

== 20210903073040 DropTranslationFormatColumn: migrating ======================
-- remove_column(:translations, :format, :string)
   -> 0.9287s
== 20210903073040 DropTranslationFormatColumn: migrated (0.9298s) =============

== 20210903085041 TranslationAddSyncColumns: migrating ========================
-- add_column(:translations, :is_synchronized_from_codebase, :boolean, {:null=>false, :default=>false})
   -> 0.7866s
-- add_column(:translations, :synchronized_from_translation_file, :string, {:limit=>255})
   -> 0.7295s
== 20210903085041 TranslationAddSyncColumns: migrated (1.5173s) ===============

== 20210918163819 CreateKnowledgeBasePermissions: migrating ===================
-- create_table(:knowledge_base_permissions, {:options=>"ENGINE=InnoDB", :id=>:integer})
   -> 0.0091s
== 20210918163819 CreateKnowledgeBasePermissions: migrated (0.0108s) ==========

== 20211025093743 Issue2429UserIdentifierValidation: migrating ================
== 20211025093743 Issue2429UserIdentifierValidation: migrated (0.0285s) =======

== 20211028094326 Issue3245Office365MicrosoftRename: migrating ================
== 20211028094326 Issue3245Office365MicrosoftRename: migrated (0.0153s) =======

== 20211118081558 MaintenanceImproveSipgateIntegrationHandling: migrating =====
== 20211118081558 MaintenanceImproveSipgateIntegrationHandling: migrated (0.0168s)

== 20211126064735 TranslationStringLength: migrating ==========================
-- change_column(:translations, :source, :string, {:limit=>3000})
   -> 0.0025s
-- change_column(:translations, :target, :string, {:limit=>3000})
   -> 0.0021s
-- change_column(:translations, :target_initial, :string, {:limit=>3000})
   -> 0.0023s
== 20211126064735 TranslationStringLength: migrated (0.0078s) =================

== 20211213105441 DropTextModuleForeignId: migrating ==========================
-- remove_column(:text_modules, :foreign_id, :integer)
   -> 0.0366s
== 20211213105441 DropTextModuleForeignId: migrated (0.0376s) =================

== 20211220145252 CreateTicketSharedDrafts: migrating =========================
-- create_table(:ticket_shared_draft_zooms, {:options=>"ENGINE=InnoDB", :id=>:integer})
   -> 0.0061s
-- create_table(:ticket_shared_draft_starts, {:options=>"ENGINE=InnoDB", :id=>:integer})
   -> 0.0057s
-- change_table(:groups, {})
   -> 0.0346s
== 20211220145252 CreateTicketSharedDrafts: migrated (0.0751s) ================

== 20220119102815 Issue3924ConfirmationDialog: migrating ======================
== 20220119102815 Issue3924ConfirmationDialog: migrated (0.0151s) =============

== 20220121101413 SettingUpdates: migrating ===================================
== 20220121101413 SettingUpdates: migrated (0.8793s) ==========================

== 20220124101834 SettingUpdates2: migrating ==================================
== 20220124101834 SettingUpdates2: migrated (0.0305s) =========================

== 20220124104955 UpdateObjectAttributes: migrating ===========================
== 20220124104955 UpdateObjectAttributes: migrated (0.0371s) ==================

== 20220124124658 PermissionUpdates: migrating ================================
== 20220124124658 PermissionUpdates: migrated (0.0315s) =======================

== 20220124132029 SchedulerUpdates: migrating =================================
== 20220124132029 SchedulerUpdates: migrated (0.0579s) ========================

== 20220124141828 OverviewUpdates: migrating ==================================
rake aborted!
StandardError: An error has occurred, all later migrations canceled:

Validation failed: Roles can't be blank
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/validations.rb:80:in `raise_validation_error'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/validations.rb:53:in `save!'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/transactions.rb:318:in `block in save!'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/transactions.rb:375:in `block in with_transaction_returning_status'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/connection_adapters/abstract/database_statements.rb:280:in `block in transaction'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/connection_adapters/abstract/transaction.rb:280:in `block in within_new_transaction'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activesupport-6.0.4.8/lib/active_support/concurrency/load_interlock_aware_monitor.rb:26:in `block (2 levels) in synchronize'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activesupport-6.0.4.8/lib/active_support/concurrency/load_interlock_aware_monitor.rb:25:in `handle_interrupt'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activesupport-6.0.4.8/lib/active_support/concurrency/load_interlock_aware_monitor.rb:25:in `block in synchronize'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activesupport-6.0.4.8/lib/active_support/concurrency/load_interlock_aware_monitor.rb:21:in `handle_interrupt'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activesupport-6.0.4.8/lib/active_support/concurrency/load_interlock_aware_monitor.rb:21:in `synchronize'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/connection_adapters/abstract/transaction.rb:278:in `within_new_transaction'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/connection_adapters/abstract/database_statements.rb:280:in `transaction'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/transactions.rb:212:in `transaction'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/transactions.rb:366:in `with_transaction_returning_status'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/transactions.rb:318:in `save!'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/suppressor.rb:48:in `save!'
/opt/zammad/db/migrate/20220124141828_overview_updates.rb:60:in `block in change'
/opt/zammad/db/migrate/20220124141828_overview_updates.rb:51:in `each'
/opt/zammad/db/migrate/20220124141828_overview_updates.rb:51:in `change'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:828:in `exec_migration'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:812:in `block (2 levels) in migrate'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:811:in `block in migrate'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/connection_adapters/abstract/connection_pool.rb:471:in `with_connection'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:810:in `migrate'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:1002:in `migrate'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:1310:in `block in execute_migration_in_transaction'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:1363:in `ddl_transaction'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:1309:in `execute_migration_in_transaction'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:1281:in `block in migrate_without_lock'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:1280:in `each'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:1280:in `migrate_without_lock'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:1229:in `block in migrate'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:1382:in `with_advisory_lock'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:1229:in `migrate'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:1061:in `up'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:1036:in `migrate'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/tasks/database_tasks.rb:238:in `migrate'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/railties/databases.rake:86:in `block (3 levels) in <main>'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/railties/databases.rake:84:in `each'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/railties/databases.rake:84:in `block (2 levels) in <main>'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/exe/rake:27:in `<top (required)>'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/bundler-2.2.33/lib/bundler/cli/exec.rb:58:in `load'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/bundler-2.2.33/lib/bundler/cli/exec.rb:58:in `kernel_load'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/bundler-2.2.33/lib/bundler/cli/exec.rb:23:in `run'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/bundler-2.2.33/lib/bundler/cli.rb:479:in `exec'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/bundler-2.2.33/lib/bundler/vendor/thor/lib/thor/command.rb:27:in `run'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/bundler-2.2.33/lib/bundler/vendor/thor/lib/thor/invocation.rb:127:in `invoke_command'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/bundler-2.2.33/lib/bundler/vendor/thor/lib/thor.rb:392:in `dispatch'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/bundler-2.2.33/lib/bundler/cli.rb:31:in `dispatch'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/bundler-2.2.33/lib/bundler/vendor/thor/lib/thor/base.rb:485:in `start'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/bundler-2.2.33/lib/bundler/cli.rb:25:in `start'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/bundler-2.2.33/exe/bundle:49:in `block in <top (required)>'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/bundler-2.2.33/lib/bundler/friendly_errors.rb:103:in `with_friendly_errors'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/bundler-2.2.33/exe/bundle:37:in `<top (required)>'
/opt/zammad/bin/bundle:121:in `load'
/opt/zammad/bin/bundle:121:in `<main>'

Caused by:
ActiveRecord::RecordInvalid: Validation failed: Roles can't be blank
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/validations.rb:80:in `raise_validation_error'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/validations.rb:53:in `save!'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/transactions.rb:318:in `block in save!'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/transactions.rb:375:in `block in with_transaction_returning_status'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/connection_adapters/abstract/database_statements.rb:280:in `block in transaction'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/connection_adapters/abstract/transaction.rb:280:in `block in within_new_transaction'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activesupport-6.0.4.8/lib/active_support/concurrency/load_interlock_aware_monitor.rb:26:in `block (2 levels) in synchronize'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activesupport-6.0.4.8/lib/active_support/concurrency/load_interlock_aware_monitor.rb:25:in `handle_interrupt'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activesupport-6.0.4.8/lib/active_support/concurrency/load_interlock_aware_monitor.rb:25:in `block in synchronize'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activesupport-6.0.4.8/lib/active_support/concurrency/load_interlock_aware_monitor.rb:21:in `handle_interrupt'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activesupport-6.0.4.8/lib/active_support/concurrency/load_interlock_aware_monitor.rb:21:in `synchronize'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/connection_adapters/abstract/transaction.rb:278:in `within_new_transaction'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/connection_adapters/abstract/database_statements.rb:280:in `transaction'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/transactions.rb:212:in `transaction'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/transactions.rb:366:in `with_transaction_returning_status'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/transactions.rb:318:in `save!'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/suppressor.rb:48:in `save!'
/opt/zammad/db/migrate/20220124141828_overview_updates.rb:60:in `block in change'
/opt/zammad/db/migrate/20220124141828_overview_updates.rb:51:in `each'
/opt/zammad/db/migrate/20220124141828_overview_updates.rb:51:in `change'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:828:in `exec_migration'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:812:in `block (2 levels) in migrate'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:811:in `block in migrate'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/connection_adapters/abstract/connection_pool.rb:471:in `with_connection'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:810:in `migrate'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:1002:in `migrate'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:1310:in `block in execute_migration_in_transaction'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:1363:in `ddl_transaction'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:1309:in `execute_migration_in_transaction'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:1281:in `block in migrate_without_lock'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:1280:in `each'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:1280:in `migrate_without_lock'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:1229:in `block in migrate'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:1382:in `with_advisory_lock'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:1229:in `migrate'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:1061:in `up'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/migration.rb:1036:in `migrate'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/tasks/database_tasks.rb:238:in `migrate'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/railties/databases.rake:86:in `block (3 levels) in <main>'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/railties/databases.rake:84:in `each'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/activerecord-6.0.4.8/lib/active_record/railties/databases.rake:84:in `block (2 levels) in <main>'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/exe/rake:27:in `<top (required)>'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/bundler-2.2.33/lib/bundler/cli/exec.rb:58:in `load'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/bundler-2.2.33/lib/bundler/cli/exec.rb:58:in `kernel_load'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/bundler-2.2.33/lib/bundler/cli/exec.rb:23:in `run'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/bundler-2.2.33/lib/bundler/cli.rb:479:in `exec'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/bundler-2.2.33/lib/bundler/vendor/thor/lib/thor/command.rb:27:in `run'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/bundler-2.2.33/lib/bundler/vendor/thor/lib/thor/invocation.rb:127:in `invoke_command'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/bundler-2.2.33/lib/bundler/vendor/thor/lib/thor.rb:392:in `dispatch'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/bundler-2.2.33/lib/bundler/cli.rb:31:in `dispatch'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/bundler-2.2.33/lib/bundler/vendor/thor/lib/thor/base.rb:485:in `start'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/bundler-2.2.33/lib/bundler/cli.rb:25:in `start'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/bundler-2.2.33/exe/bundle:49:in `block in <top (required)>'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/bundler-2.2.33/lib/bundler/friendly_errors.rb:103:in `with_friendly_errors'
/opt/zammad/vendor/bundle/ruby/2.7.0/gems/bundler-2.2.33/exe/bundle:37:in `<top (required)>'
/opt/zammad/bin/bundle:121:in `load'
/opt/zammad/bin/bundle:121:in `<main>'
Tasks: TOP => db:migrate
(See full trace by running task with --trace)
# Updating translations...
nil versions are discouraged and will be deprecated in Rubygems 4
nil versions are discouraged and will be deprecated in Rubygems 4

# Configuring Elasticsearch...
nil versions are discouraged and will be deprecated in Rubygems 4
WARNING: plugin [ingest-attachment] was built for Elasticsearch version 7.17.1 but version 7.17.3 is required
WARNING: plugin [ingest-attachment] was built for Elasticsearch version 7.17.1 but version 7.17.3 is required
-> removing [ingest-attachment]...
-> Installing ingest-attachment
-> Downloading ingest-attachment from elastic
[=================================================] 100%  
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@     WARNING: plugin requires additional permissions     @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
* java.lang.RuntimePermission accessClassInPackage.sun.java2d.cmm.kcms
* java.lang.RuntimePermission accessDeclaredMembers
* java.lang.RuntimePermission getClassLoader
* java.lang.reflect.ReflectPermission suppressAccessChecks
* java.security.SecurityPermission createAccessControlContext
See https://docs.oracle.com/javase/8/docs/technotes/guides/security/permissions.html
for descriptions of what these permissions allow and the associated risks.

-> Installed ingest-attachment
-> Please restart Elasticsearch to activate any plugins installed
nil versions are discouraged and will be deprecated in Rubygems 4
# Enforcing 0600 on database.yml ...
# Starting Zammad
# Creating webserver bootstart
Synchronizing state of nginx.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable nginx
# Restarting webserver nginx
####################################################################################

Add your fully qualified domain name or public IP to servername directive of
nginx, if this installation is done on a remote server. You have to change:
/etc/nginx/sites-available/zammad.conf and restart nginx process.
Otherwise just open http://localhost/ in your browser to start using Zammad.

####################################################################################

Steps to reproduce the behavior:

  • I can reproduce when i launch
    dpkg-reconfigure -plow zammad

Just to make sure, in your current version, Settings → Roles is not blank, I guess?
And you can view/edit all of the roles?

Same with the Overviews?

1 Like

Hello TomGem,
no problem on the side of the roles but on the other hand there were 3 overviews without a role selected in the column “Available for the following roles”.

after having defined roles for these 3 overviews, I reexecuted dpkg-reconfigure -plow zammad and the update was complete.

Thank you for your reply and have a nice day.

1 Like