Update operating system

Hi,
I have a debian 10 with zammad 5.0.3 source installation. The plan is to update to debian 11. I know how to update debian, but I am worried to destroy my zammad. Is there any documentation about updating the operating system on which zammad runs?
Thanks,
Christian.

Hey,

the answer probably depends on your installation type and your used components (webserver/db). Since you didn’t provide any information about this i’m just giving you my experience with this:

We’re using the packaged version and i didn’t have any problem regarding zammad itself while going from Stretch to Buster. I expect the same for my pending upgrade to Bullseye.

The only thing that can be a little tricky - if you’re unfamiliar with it, like i was - is doing a major upgrade on your postgresql db (if you’re using this). Since you most likely are going to do exactly that going from Buster (pg 11) to Bullseye (pg 13) you should look that up first because it can be time-consuming.

Regardless which webserver you use either one shouldn’t really be trouble at all.

cheers

1 Like

If you’re using SSO make sure to check out this thread.

Summary: Zammad’s SSO implementation has a depency for the libapache2-mod-auth-kerb package which is not available on Debian 11 due to recently discovered security flaws. You’ll have to backport the fixed version from the Debian unstable channel to make SSO work. We tested this in conjunction with an Active Directory domain and can confirm it’s working on our test vm .

2 Likes

Hi,
thanks for the quick respronse. The update of Debian is simple. And than I have only to change the url of zammad in the apt source list.
BUT than I run exactly into the mentioned issue with PostgreSQL. The Debian update simply installs version 13 additionally to version 11.
Now I can’t access Zammad anymore. Not a big deal, I restored my Snapshot, but I would like to be able to do the Debian update for my Zammad machine.
By chance, do you have any Information how to do the PostgreSQL thing for Debian 11?
Thanks,
Christian.

I had a look at our internal blog and really found the commands i used back then :smiley: .
There are probably tons of better ways to do that but it worked for me. Maybe it works for that upgrade too. Otherwise you need to consult almighty Google i guess.

Danger Zone

Use at your own risk and better yet: have a backup (since you’re using snapshots you should be fine).
Anyone else reading this: keep in mind that all your data can be lost if stuff goes downtown while doing this.

pg_ctlcluster 9.6 main stop && pg_ctlcluster 11 main stop
pg_dropcluster --stop 11 main
pg_upgradecluster 9.6 main
pg_ctlcluster 11 main start
pg_dropcluster 9.6 main
apt remove postgresql-9.6 postgresql-client-9.6

You’d want to adjust the version numbers, obviously.

cheers

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.