Unable to send mail after OTRS migration

Used Zammad version: 2.4.0
Installation method: Package
Operating system: Debian 9, CentOS 7 x64
Database + version: 5.1 Distrib 10.1.26-MariaDB(Debian), PostgreSQL 9.2.23 (Centos)
Elasticsearch version: 5.6.8
Browser + version: ALL Browsers
Expected behavior:

I run 2 Zammad Instances. The first one was installed from scratch on a Debian 9 server with above details. Email account was added and worked (send/receive) with no issues at all

I decided to set up another instance to replace our current OTRS. This was set up on CentOS with the above details.
OTRS Migration was successful but I am unable to add a mail account - no matter what i do it gets stuck on ‘verifying sending and receiving’

The IMAP/POP account verification obviously works as Zammad can see how many mails are in the inbox, but SMTP verification fails.
I’ve tried multiple different external mail servers and sendmail and postfix.
While trying to add the mail account to Zammad I watched the mail server logs, and not once has an SMTP connection attempt been made by Zammad

After giving up on the CentOS system I re setup Zammad on a brand new Debian server, performed the migration again and have the exact same problem. All data has come across from OTRS but i am unable to add any mail accounts again

The First Zammad we use for other purposes and which was setup from scratch (no migration) is succesfully connecting to the mail servers that the second instance is not.

I cannot find any useful log information to give, as it appears nothing is even trying to connect to SMTP.

production.log output when trying to add the mail account:

INFO – : Parameters: {“adapter”=>“pop3”, “options”=>{“host”=>“mail.[redacted].net”, “user”=>“internal@[redacted].net”, “password”=>"[FILTERED]", “ssl”=>true, “port”=>“995”}}
INFO – : fetching pop3 (mail.[redacted].net/internal@[redacted].net port=995,ssl=true)
INFO – : check only mode, fetch no emails
INFO – : Completed 200 OK in 603ms (Views: 0.3ms | ActiveRecord: 0.7ms)
INFO – : Started POST “/api/v1/channels_email_outbound” for at 2018-04-19 22:24:21 -0400
INFO – : Processing by ChannelsEmailController#outbound as JSON
INFO – : Parameters: {“adapter”=>“smtp”, “options”=>{“host”=>“mail.[redacted].net”, “user”=>“internal”, “password”=>"[FILTERED]", “port”=>“587”}, “email”=>“internal@[redacted].net”}
INFO – : Completed 200 OK in 8ms (Views: 0.2ms | ActiveRecord: 0.4ms)
INFO – : Started POST “/api/v1/channels_email_verify” for at 2018-04-19 22:24:21 -0400
INFO – : Processing by ChannelsEmailController#verify as JSON
INFO – : Parameters: {“inbound”=>{“adapter”=>“pop3”, “options”=>{“host”=>“mail.[redacted].net”, “user”=>“internal@[redacted].net”, “password”=>"[FILTERED]", “ssl”=>true, “port”=>“995”}}, “outbound”=>{"$
INFO – : fetching pop3 (mail.[redacted].net/internal@[redacted].net port=995,ssl=true)
INFO – : verify mode, fetch no emails
INFO – : Scheduler running…
INFO – : Running job thread for ‘Process escalation tickets’ (Ticket.process_escalation) status is: sleep
INFO – : Started job thread for ‘Process auto unassign tickets’ (Ticket.process_auto_unassign)…
INFO – : execute Ticket.process_auto_unassign (try_count 0)…
INFO – : …stopped thread for ‘Ticket.process_auto_unassign’
INFO – : execute Channel.fetch (try_count 0)…

If I understand the sourcecode correctly, this message indicates that zammad tests/tested the POP3-Account for functioning.
Could you please post your E-Mail-Account configuration from zammad?
Also your full, redacted, production.log would be great :slight_smile:

Production.log: https://defuse.ca/b/bXbyAG1wUctCiHm7IAk9oa

Mail config: i have tried using both POP/IMAP SSL/No SSL. The credentials and server details work fine in thuderbird/outlook but not zammad.

The exact same problem happens after OTRS migration on a centos and debian system

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.