Trouble changing to new postgres-server

Hi,

I’m using the centos 7 package of zammad. It was installed with the stock 9.2 postgres server (default port 5432), and now that i would be able to upgrade zammad from 4.1.0 to a more recent version, i need to upgrade postgres to a more modern version.

I have now running on the same server postgres 13 on a different port (5433), and i created a dbdump from the old 9.2 and imported it to the new postgres 13. In zammad i changed the db-settings in /opt/zammad/config/database.yml to reflect the change for new port. I also added a password to the new pg13 zammad-user which i set in the config.

Unfortunately this did not work, and i get instead the 500: We’re sorry, but something went wrong-error page.

I tried also to just switch the new database to port 5432, removed the zammad-users password, but I still get the same 500-error.

Any ideas what I might have done wrong? I dumped the db with the following pg_dump parameters pg_dump --no-privileges --no-owner (/usr/bin/pg_dump -p 5432 --no-privileges --no-owner -c zammad | /usr/pgsql-13/bin/psql -p 5433 -d zammad)

Any help with this would be appreciated…