Triggers not working

Infos:

  • Used Zammad version: 3.1.X
  • Used Zammad installation source: Cent OS 7
  • Operating system: Windows 10 Enterprise
  • Browser + version: Version 78.0.3904.108 (Official Build) (64-bit)

Expected behavior:

  • Send acknowledgement notification email to customer when he/she creates new ticket

Actual behavior:

  • Agents receive help desk emails that a new has been created. Customers do not receive any emails acknowledging that their ticket is received and getting the required attention. Email is not sent to the SMTP server. Notifications appear on the help-desk dashboard

Steps to reproduce the behavior:

you need to add email account

The Email notification is only for notifications etc…

but for outgoing you need to add email account. you have an option to add only outgoing please read at the documentation how. https://admin-docs.zammad.org/en/latest/channel-email/sendmail.html

also configured every agent group.

Thank you

Thank you very much for your assistance.

Managed to create an email for outboud emails but my sendmail protocol is on amber and not green as it is supposed to be. What could be the cause?

No sent mail yet?
It will change to green if it used it successfully.

If it’s not successfully, check your logs.

Hello

I am still unable to get zammad to send emails to customers upon creation of a new ticket. The outbound status still not turning green.

The command executed sucessfully without any errors.

The above command created an outgoing (only) email channel.
Please note that for triggers to work (when sending a mail), you need to add the mail address to your group.

See: