Triggers not working anymore


  • Used Zammad version: 5.2.x
  • Used Zammad installation type: package
  • Operating system: Windows 10 Enterprise
  • Browser + version: Chrome 105.0.5195.102

Expected behavior:

  • The default triggers like auto-reply (on new ticket) should work and send a E-Mail to the “Customer” if a new Ticket is created.

Actual behavior:

  • No E-Mail is send out, they don’t trigger.

A couple of weeks ago the Triggers all worked fine with no problems. Suddenly from a day to another they stopped working. Nothing has changed on the System. We’ve tried everything we could find on this Forum, a Mail is set on each specific group. We checked our E-Mail Server and everything… nothing to find.
Last week we updated the machine and services. Somehow the triggers worked again but the search function (I guess elasticsearch) hasn’t worked anymore and for no explainable reason whole zammad wasn’t working the next day. So we used our Back-up of the VM and repeated the process. Zammad and elasticsearch were working fine, but the triggers still aren’t working anymore.

I realy can’t explain the issue on this one. It worked fine we changed nothing and still it’s not working anymore.
In the production.log is nothing to see about a trigger reacting. It’s like they don’t exist/show up.

Anyone can help?

Thanks alot.

If you changed nothing the trigger will work without any change.
This can have two reasons:

  • The user mail address is not working and Zammad learned that. This would mean that the triggers works some times and some times not.
  • There was a change in either the trigger configuration or the group (e.g. no email address configured).

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.