Trigger doesn't change ticket state to 'Pending Close'

  • Used Zammad version: 3.2.0-1578664361.375c4929
  • Used Zammad installation source: Debian Package
  • Operating system: Ubuntu 18.04
  • Browser + version: Firefox 72.0.1

Expected behaviour:

I have a trigger setup in schedular:

  • When the trigger runs, it should take any ticket with no contact from the customer for 1 minute (short time for testing purposes) and:
  1. Send chase email to customer
  2. Change the ticket state to ‘pending close’

We’re using the ‘pending close’ as a holding pen for quiet tickets, so another scheduled trigger can monitor them and automatically close after a specified time of no contact

Actual behaviour:

  1. Send email to customer - Works
  2. State of ticket did not change

Steps to reproduce the behaviour:

Setup the following trigger in schedular:

Monitor until it runs, check ticket state.

Pending close or pending action / pending reminder states consist of two fields.
As you’re not setting the pending till, the desired action is technically not possible.

Also please note that currently pending till configurations in triggers and schedulers are always absolute.
Relative settings are not supported at this moment.

Ah that’s what we expected! Thanks for the info

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.