Tags unavailable if more than 10 results


  • Used Zammad version: 5.0.3
  • Installation method (source, package, …): package
  • Operating system: Ubuntu 20.04
  • Database + version: package
  • Elasticsearch version: 7
  • Browser + version: Chrome 98.0.4758.102, Edge 98.0.1108.62, Firefox 97.0.1

Expected behavior:

Conditions: New Tags toggle off, with over 11 tags in the system created by Admin that will match criteria
Ticket or Trigger tags fields: Typing a tag that exists within the system should display a dropdown list showing ALL tags that match criteria. Selecting “Enter” should allow selection of a tag (provided it exists) without selecting from the dropdown. Starting to enter the tag should start the autocomplete search with what you typed, not search in the middle of a tag.

In regex terms for this example: ^\w.

Actual behavior:

*Typing the beginning characters or entirety of a tag returns only up to 10 options in the autocomplete, even if an exact match would be further down the list on the Settings\Tags page. You can only add the tag by selecting it from the list, even if the tag is present in the system exactly as typed. Selecting “Enter”, “Tab” or “Shift+Enter” will not add the tag.

In regex terms it appears to search the following: \w.

Steps to reproduce the behavior:

  1. Create the following tags: 11A,11A1,11A2,11A3,11A4,11A5,11A5,11A6,11A7,11A8,11A8,1A
  2. In either a trigger or a ticket, attempt to enter the tag “1A”
  3. Dropdown list will only populate to option “11A8” (or whichever option is the 10th option) and selecting any terminating key (Enter, Tab, Shift+Enter) nor clicking outside of the tags field will add the tag of “1A” (even though it already exists in the system).

Further testing:
Increased the size of the viewport to display more results, with no extra results being displayed. I believe the autocomplete itself is limiting to 10 results. I cannot find where to change this, however. Turning back on the allowing creation of tags allows one to select Enter to select the correct tag (if it is an exact match).

Any suggestions to figure out either how to change the autocomplete dropdown to show more than 10 results or make the search more restrictive or allowing entering tags by pressing the Enter key with tag creation disabled (tag already in system)?

This is still an open issue. I cant find in the code where to change this. I’ve tried so many things, I can’t remember what I’ve tried. Anyone with any insight?

Zammads UI limits the number of objects it returns. If This has several reasons, one of them is space.
If you agent starts to type then it will adjust the results based on the agents search.

If you want a list someone can scroll through (why ever one would want a 100 options long list all the time) then you may wanna use objects instead: Objects — Zammad documentation

@MrGeneration thanks for the update. If I could make the autocomplete more exact it would fix the issue. The problem is that “3.A” returns “13.A” and “13.A.(1-8)” and “113.A.(1-08)”. Which clocks 3.A from being selectable. As it is a UI limit this can be closed.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.