Support for Proxy Protocol on Kubernetes (Helm Chart)

  • Used Zammad version: 5.0.3
  • Used Zammad installation type: helm
  • Operating system: Kubernetes
  • Browser + version: Firefox 96

Expected behavior:

The nginx which is bundled in the chart should pay respect to proxy protocol header which is set by the load balancer (ingress)

Actual behavior:

  • All session logs within zammad show the internal IPs of the cluster for all users (e.g. 10.2.0.18)

Steps to reproduce the behavior:

  • Install the helm chart to a kubernetes cluser
  • Enable ingress support
  • Login to Zammad
  • Open Settings → Sessions

Did anybody solve the issue about parsing proper client-id headers? Those could either come from an kubernetes Load balancer (my case) with proxy protocol enabled or some internal cluster load balancer e.g. haproxy.

As far as I’m aware the docker-compose (and thus helm as well) does not expect the nginx container not to be the direct server to be contacted initially. Thus you’re use case is technically not supported by the stack.

Correction… there’s possibilities.
https://docs.zammad.org/en/latest/install/docker-compose/environment.html#zammad