StatusCode: 500 after complete fresh installation

Expected behavior:

  • Open the Reporting “Ticket Count” and “Create Channels” without error code

Actual behavior:

  • When i open the Reporting “Ticket Count” and “Create Channels” i always get this Error Code:
" {"error":"Unable to process GET request to elasticsearch URL 'http://localhost:9200/mydomainname_zammad_production/Ticket/_search'. Check the response and payload for detailed information: \n\nResponse:\n#\u003cUserAgent::Result:0x000055f7b2ee8748 @success=false, @body=nil, @data=nil, @code=\"404\", @content_type=nil, @error=\"No such file http://localhost:9200/mydomainname_zammad_production/Ticket/_search, 404!\"\u003e\n\nPayload:\n{:query=\u003e{:bool=\u003e{:must=\u003e[{:range=\u003e{\"created_at\"=\u003e{:from=\u003e\"2019-12-31T23:00:00Z\", :to=\u003e\"2020-12-31T22:59:59Z\"}}}], :must_not=\u003e[{\"term\"=\u003e{\"state.keyword\"=\u003e\"merged\"}}]}}, :size=\u003e0, :aggs=\u003e{:time_buckets=\u003e{:date_histogram=\u003e{:field=\u003e\"created_at\", :interval=\u003e\"month\", :time_zone=\u003e\"Europe/Berlin\"}}}, \"sort\"=\u003e[{:updated_at=\u003e{:order=\u003e\"desc\"}}, \"_score\"]}\n\nPayload size: 0M"}"

Steps to reproduce the behavior:

  • If you do the installation in order of the steps and the certbot installation and the end, you get the same error code message. In the etc_nginx_sites-available_zammad.conf just change the localhost and nothing else.

I know their are a lot of topics with this error code, but i think it might be something really simple but i dont know. I also got another problem, but i will open a new topic for this.
Maybe you can help me. I wish you a good day and stay healthy.

The issue you describe is a non functional elasticsearch installation.
Please follow the instructions on our documentation for elasticsearch and ensure it’s running and you can reach it.

Our elasticsearch guide lives here:

If systemctl status elasticsearch shows it’s running, you proberbly installed the wrong attachment plugin (if it’s even installed…).

You can also run curl http://localhost.9200 to check if your ES responds as expected - the output looks similar to the below:

zammad:~# curl http://localhost:9200
  "name" : "zammad",
  "cluster_name" : "elasticsearch",
  "cluster_uuid" : "xxxx666xxxxx",
  "version" : {
    "number" : "7.3.1",
    "build_flavor" : "default",
    "build_type" : "deb",
    "build_hash" : "4749ba6",
    "build_date" : "2019-08-19T20:19:25.651794Z",
    "build_snapshot" : false,
    "lucene_version" : "8.1.0",
    "minimum_wire_compatibility_version" : "6.8.0",
    "minimum_index_compatibility_version" : "6.0.0-beta1"
  "tagline" : "You Know, for Search"

Thank you, that was my solution. After a “fresh” elasticsearch installation and a reboot everything was working fine.
2 problems solved with 1 solution. Thanks again.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.