SSO option missing


  • Used Zammad version: 3.5.0
  • Used Zammad installation source: package
  • Operating system: Debian 10
  • Browser + version: Firefox 78.4.0esr

Expected behavior:

  • Having an option to enable SSO authentication in the thrird party application section

Actual behavior:

  • Not having an option to enable SSO authentication

Steps to reproduce the behavior:

  1. initially installed zammad version 3.3
  2. database is migrated to a seperated Server
  3. Updated to latest version via apt
  4. setup kerberos auth as descriped in the latest zammad documentation

I now get this error message when opening /auth/sso:

Our release notes provide the needed hint…

" The SSO functionality now needs to be activated via Admin → Security → Third-party Applications → Authentication via SSO"

If you can’t find the option, your upgrade probably isn’t completed successfull.
Check your migrations.


Thanks for the quick reply. You are right. The migration failed at creating a smime_certificates table and some index. we had to enable innodb_large_prefix and set innodb_default_row_format to dynamic as descriped at:

afterwards i deleted smime_certificates and run “zammad run rake db:migrate --trace” and the migration worked.
The option is now available and is working correctly.

Thanks again,

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.