Some users allways become Inactive users


  • Used Zammad version: 2.7
  • Used Zammad installation source: (source, package, …) RPM
  • Operating system: Centos7
  • Browser + version: chrome 74.0.3729.169

Expected behavior:

Creating a user from LDAP sync
Giving the user Admin and Agent permissions
The User is in Active state

Actual behavior:

  • after some time the user become Inactive for no reason

Steps to reproduce the behavior:

  • Assign permission to a user ( LDAP sync user ) and wait for a while

Hey @ronenu,

welcome to the community!

What exactly do you mean by the user becomes inactive?
Are the admin/agent permissions you manually granted revoked OR are you really talking about the ACTIVE * dropdown OR even both?


Also please provide the configuration of the ldap integration, I guess you got a rotten rat in there.

Hi ,
the user is actually become inactive ( like you disabled him manually )
my guess is that it happen after LDAP sync.

i was looking for error messages over the production.log file and i saw this errors

where can i search to find what email address is in used by other user ?

thank you.


well one safe way would be to look up the inactive zammad user in your LDAP source. The email address should be stored there.


Checking the LDAP source was the first thing I did.
I didn’t find any duplicate email address there

is there any log in Zammad where I can look for the source of this error ?

Please provide a logfile that’s not out of context like above.
This error can have several sources:

  • your agent trying to create a new user
  • your admin trying to create a new user
  • ThirdParty authentication when you don’t automatically link an account on initial login (if the account already exist locally)
  • API magic you do

Normally the LDAP sync shouldn’t be affect.

Another note as I just saw it: You might want to upgrade Zammad from 2.7 to at least 2.9, as there have been fixed security issues that your installation currently doesn’t have.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.