[solved] Zammad not starting after current update

Infos:

  • Used Zammad version: current (2.8.0-31)
  • Used Zammad installation source: Docker
  • Operating system: CentOS 7
  • Browser + version: Safari (newest)

Expected behavior:

  • Zammad should start after updating :wink:

Actual behavior:

  • Zammad won’t start after updating.

  • Init-Container shows same error over and over again

    rsync: change_dir “/tmp/zammad-stable/ /opt” failed: No such file or directory (2)
    rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1196) [sender=3.1.2]

Steps to reproduce the behavior:

  • Update to current Zammad docker image

Are you using a stock docker image or have you edited e.g. the compose file?

Stock, docker-compose. I do have a docker-compose.override.yml file—but it only changes the port for nginx because 80 is in use by Plesk.

Looks like it’s exactly this problem:

I guess that the docker currently doesn’t like it too much… maybe @monotek can help here?
My knoewledge with docker is… well… not enough :smiley:

I don’t think it’s the same issue. In the linked bug, the railsserver won’t start; it tries to listen on IPv6, and apparently the host doesn’t support that. Maybe it’s disabled in the kernel?

In this case, the init container is definitely broken: https://github.com/zammad/zammad-docker-compose/issues/94

1 Like

The following change fixed for me:

zammad.iserv.eu ~/zammad-docker-compose # git diff .env
diff --git a/.env b/.env
index 5d7c3f1..09e5f09 100644
--- a/.env
+++ b/.env
@@ -1,5 +1,5 @@
 # don't forget to add the minus before the version
 # example: VERSION=-2.1.0-13
 IMAGE_REPO=zammad/zammad-docker-compose
-VERSION=
+VERSION=-2.8.0-31
 RESTART=always
\ No newline at end of file
docker-compose pull
docker-compose up -d

Just don’t forget to remove it when you want to upgrade at a later date :slight_smile:

5 Likes

Thank you very much – up and running again!

We should start issuing medals / awards. :slight_smile: :rocket:

1 Like

Dear @martin.von.wittich, in the linked GitHub issue someone asked:

Actually, not using any tag at all. I’ve just set it up like described here: https://docs.zammad.org/en/latest/install-docker-compose.html

What is the proper way to configure it? Put a specific version numer into .env?

Unfortunately this question has not been answered yet. I thought maybe you could elaborate.

I understood (from the link) that not using any tag within the .env file means Docker will always pull the latest changes. Of course I’d love to stay on a particular (stable) version until the newer (stable) update comes out.

Thanks!
Ben

@MrGeneration Could you have a look, please? :slight_smile:

Please always use version tags.
Normally all you need to do is stay within the current version number (today it’s 2.9.x) so something like *2.9.0-5 in your tag.

I’ve taken a look, it looks like we’re only pushing stable to docker-hub so you should be fine with any version.

I’m not sure if this answers your question. To be honest I’m not too much of a Docker-Guy yet… :x

Could you explain the versioning a little more? If 2.9.0 is stable, what is 2.9.0-5? (Smaller fixes?)

Thank you!

2.9.x is our current stable

Patches/Updates within the Subbranch (x) are most likely very small changes or fixes only ( you can see what it is about here: https://github.com/zammad/zammad/commits/stable )

Those changes are only changes we see as safe/stable. Bigger code changes will not be pushed to stable in between two versions. Please note that I can’t give you detailed information in terms of docker versioning, as it doesn’t have to be a daily built and might “lack” some days of commits from github.

Generally you don’t need to update it every 3 days or so, it’s safe to stay at a defined tag, except if you’re experiencing bugs that are fixed in stable already (or there’s a new bigger version).

I hope this helps.

I still don’t understand the difference between 2.9.0-5 and 2.9.0-6, but the rest is clear :slight_smile:

Proberbly just super small code changes. I can’t tell you in detail (I just don’t know) sorry!

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.