[solved] Zammad basic Installation issues: nginx and elasticsearch

Hi everyone. I’m trying to install zammad on CentOS 7, but have encountered with two issues:

  • First of all, after installing according to documentation, when i go to http://localhost it shows nginx demo web page, and not zammad first screen.
  • Second, when i issue this command: zammad run rake searchindex:rebuild, it shows “rake aborted! Version 6.5.4 of configured elasticsearch is not supported”

I’d appreciate very much for your assistance.
Best regards,

I think you problem with elasticsearch is the Version how you can see it in you message. In the Documentation you can also read which version of Elasticsearch is supported:


Set up Elasticsearch
We use Elasticsearch for the awesome search in Zammad.

Currently we support:

Elasticsearch 2.4.x to 5.5.x with mapper-attachments plugin
Elasticsearch 5.6.x with ingest-attachment plugin

Remove you current Elasticsearch Installation and install a supported version. This Site helped me a lot because iam not so deep into Linux:


And to your second problem. Did you activated the firewall and configured it propably? When not i would disable the firewall temporaly and try it again.

Thanks very much for your reply! Following the steps you pointed me at, were successfull for my first issue.
However, i still get the default nginx page, and not zammad web page when accessing to http://localhost/.
Any further help, will be very appreciated.

I can see a similar topic here:

However, in my case, trying to access locally won’t do… (curl http://localhost or IP number)

Best regards,

Just for the record. Everythong worked fine, just changing localhost to the static IP address assigned to the server.
Thanks to all. This topic can be closed

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.